Why the heck is Settings so confusing to navigate?

Over time, Settings has become more convoluted and it has gotten to a point where I need to traverse nearly all the options to find what I’m looking for.

There is nearly no hierarchy of how these options are grouped and divided.

Empty new lines (separators) have been removed in favor of stacking all options in a single card.

I find the hierarchy quite logical. For example today when helping someone on discord I guessed that time zone settings would be in Settings → System → General before even checking I was right.


There are many settings, that need a place. I think it would help if some concrete examples were provided. What is the thing (or things) you can’t/could not find?


The page that displayed startup times for integrations, the last time I was wondering around.


The most illogical place for me was Settings → System → Hardware to see “Generic x86-64”. Now at least I also see CPU and memory utilization.

Only thing I still don’t like is that the “” menu too often just hides some useful data. The “menu” in not the right place to get details or additional info. It should be more a “context” menu for current view itself.


It may be good to add a search field that search inside the settings like you can search in macOS settings


I have to agree here, since last Settings redesign, I feel like options have been scattered into too many places.

Let’s say I want to restart Home Assistant. OK obviously System. Then what? General? No. Updates? No. Oh look there is restart text hiding in the top right corner.

OK now I want to reload automations. In old settings this was on the same screen as restart (which kinda made sense, it was common reloading/restarting screen). It is not under automations. does not appear to be under System. After couple of minutes of searching I Googled for it and it looks like it’s been moved to Developer Tools.


Than nothing. It is on the system menu directly.

I really wouldn’t call that hiding. If it were in a kebab menu, I would agree with that comment, but it is prominently placed, in an actionable color, and always visible.

1 Like

This exists. Type ‘c’ then start typing what you’re looking for. Can jump to pretty much any place in settings/dev tools or launch any actions. For example:

Type ‘c’ then type ‘restart’. Select restart home assistant

Type ‘c’ then type ‘reload’. Select reload automations.


Ohh, I didn’t even know that there is “Check for updates” under Settings menu…

And Restart is in Settings → System view. Not in under menu dots but just there on the right corner. I didn’t notice this ether and always restarted from Developer Tools → YAML tab…

Looks like the UI is still much bigger mess than I have found so far. Good thing is that it goes better with every release.


That is not where buttons should be placed. This is terrible UI.


I also spent some minutes searching for the “Restart” button :rofl:


It is confusing and also changes, so as a user I have to relearn where some things are located regularly, but I hope that those changes or for the better.

I even keep my UI in english to keep it less confusing.

When I want to add another zigbee device to ZHA I need to go to Devices & Services, then the ZHA integration and then Add devices. In the Settings view, searching for “Add device” does not give a result and searching for “zigbee” lists the scripts that I created myself.
Maybe one could allow the integrations/components define a list of search terms (& relative links) to make the search more efficient. That could be listed in the component’s JSON for instance. ZHA would list “Add device”, “View topology”, “Refresh topology”, etc. to link to the page/service/etc.

1 Like

Settings search has pretty much solved this problem for me, and aligns to other systems where I do this (iOS, windows etc)

1 Like

One example that is not intuitive to me and had to search the community (System information settings page - Installation / Home Assistant OS - Home Assistant Community (home-assistant.io)) is where to get the system information settings on the hardware. I’d logically think System → About or System → Hardware but as pointed out in this link; it’s System → Repairs → … in top right → System Information. I also tried the shortcut menu but it wasn’t there either.


I think the issue is that all the miscelaneous settings (including those in the menus in the individual settings pages) are always going to be tricky to classify.

Perhaps it simply needs a search functionality? Like how settings works on modern android phones for example.

Yeah I think thats really the point. Why not have it in the stack in the middle of the screen with everything else.

1 Like

I created this thread based off not being able to find that exact menu.

Who would think that system information would be categorized under “Repairs”?

It’s pretty clear that the design decisions have been very one-sided and there is a clear disregard for established design guidelines.


Ok, so I have to remember to press c… How do I do that? F for find or S for search would be logical in my world. But C?


“C” as command and “E” as entity, I guess.