Widgets work for anyone on android?

Using 1.7.0 and when I try to add a widget it all goes ok. I get it all setup and the widget is on the screen. When I hit it I get a spinning icon like it’s trying to do something, but it fails every time. I see it go red at the end.
I’ve tried lights and switches all of which are controllable in the app, but none work.
I searched, but only found a couple results for widget so it doesn’t seem many people have used them or had an issue with them anyway.

Anything I can check?

Thanks

Widgets are working for me, make sure the service data is correct when you set it up. Feel free to post a screenshot if you can’t get it to work so we can see whats going on with the service data.

Not for me. I can drag a widget onto the sceen, but the app is crashing almost immediately. It worked in version 1.5

Can you run a quick check to see if the new notification features are working too? Wondering if you need to clear data in the app and start fresh to fix the issue. 1.7 and 1.6 included several fixes for widgets. Make sure you are on 1.7 as 1.6 had some issues.

I reinstalled version 1.6 after having trouble with notifications and widgets. Notifications started to work again, but not the widgets. And nothing changed with version 1.7

And the same happens on my wife’s phone. She also have version 1.7
I suspect there is something with the data the app is loading from HA, but I don’t know what and it worked in 1.5

@stigvi by reinstall I assume you cleared data and ran through the clean up steps: https://companion.home-assistant.io/docs/troubleshooting/faqs/#starting-fresh-with-the-android-app

If so please file an issue with all details in the template.

After doing this it works for me now.
Thanks for helping out!

1 Like

In version 1.7.1 and 1.7.2 I get a message in the widget that a custom component is preventing service data from loading.

I have no idea of which custom component and why…

Something I noticed is that I had to recreate existing widgets (made prior to 1.6) once I had upgraded. I didn’t have to do a cleanup or reinstall the app, just delete and re-setup the widgets themselves.

Check with your custom components for any updates. Usually the issue is invalid services.yaml

Thanks. It was circadian lighting having an empty fields section.

1 Like