Wierd behaviour in config of groups and views


I’m new to HA so I need some info and guidance but loving the application already.
I noticed following during config, when I add a view with identifier ‘defaut_view’ as first view, I don’t see any sensors on the page. When I use the identifier ‘home’, the sensors pop up but then I have this on my tabs:
I have the text home tab and one with the icon.
I don’t want the text tab but I do want the sensors on my default page.
How can I fix that?


post the groups section of your configuration.yaml file so we can see the code.

make sure you follow the instructions at the box at the top to properly format the code.

    view: true
    icon: mdi:home
        - group.eetkamer
        - group.woonkamer
        - group.bureau
        - group.cameras
    view: true
    icon: mdi:lightbulb-on-outline
        - group.allelichten
    view: true
    icon: mdi:cctv
        - group.webcams
    name: Webcams
        - camera.garage
        - camera.tuin
        - camera.woonkamer
        - camera.tv
    name: Woonkamer
        - light.woonkamer
    name: Eetkamer
        - light.eetkamer
    name: Bureau
        - light.bureau
    name: Alle lichten
        - light.bureau
        - light.woonkamer
        - light.eetkamer

The reason that you have a “Home” tab and a tab with the home icon is because you haven’t defined a default view so, by default, the “Home” tab is enabled. And since you also created another tab called Home with the icon then it also creates that tab. Just to test that you can either get rid of the icon or change the name of the “home” group. You can’t change the name of the default “Home” view.

Next, if you do define a “default_view” then the default “Home” view is removed and is replaced with the one you just defined. The problem there is then that you have to define everything that you want to show up on your new “default_view”. It will no longer show everything on there by default.

You have two options.

The first option is to leave the group config the way it (with no default_view defined) is but change the icon or the name of the group you called “home”. That will leave all of the entities showing up on your “Home” tab. Then you can put all of the entities you want on the other tabs.

The next option (and the option most people end up using) is to define a default_view and then just put only the entities you really want to see all the time on the newly created “home” group (which will also be the “default_view” if you define it that way).

Ok, now I understand.
Thanks for the info.
I went the default_view route and changed the icons to what I want.
Seems to work best for me for now.