Wifi connection from PC

I’ve installed Home Assistant for Generic x86-64. I’ve used an ethernet cable to perform the setup. Now I need connect this PC by wifi. I’ve tried solutions found on some tutorials, like using for example an USB stick with configuration folder and my-network file, but I can’t select wifi when I try to change IP

. It seems that Home Assistant doesn’t recognize my wlan hardware? I’m using a HP 260-a110ns.

Thanks in advance, and sorry for my english. :rofl:

If you used Ethernet, then that’s what HA is configured for, wifi-interface is not enabled, maybe not even reconiced, by either HA - OS or VM(if your running VM)

is there a way to enable/recognize wifi interface? I’ve got the same issue on mini pc bmax b2 pro.

probably, the ways depends upon which HA(VM, Supervisor, HAOS etc. ) you are running, and whether its builtin or via USB
Don’t ask me how, i have never even EVER thought about running a server over WIFI(2 Ethernet, but NEVER WIFI)
EDIT: well i have had a few apache-webservers in VM-ware on windows for testing/dev purpose(easy to configure in VMware)

I installed HAOS in a mini pc following the home assistant procedure and all works fine expect wifi.
In System>Network I don’t have wifi options.

if there is a builtin wifi, you need to search this forum for configure(or run) wifi on HAOS, as it’s a Linux core , i think it’s either wlan0/wlan1 or wlpxxx. Thou again, it’s NOT recommended, AND maybe your buildin wifi device is not supported by the HAOS(build) , if not you could try with a USB(make sure that one is supported, and use that “USB” in your search term)
Open a new Topic, as you see the Orig Poster here didn’t get responses here, so it’s a bad idea asking in same “old” topic, and i run a vmware in windows, AND would never use wifi for a HA-server(most wont, so maybe thats why the OP didn’t get response , and you might just get same advice multiple times

Don’t use WiFi, it will flood your WiFi network if you do not tweak the WiFi network settings. Or do you use Home Assistant for 1 light? :wink:

Maybe you can re-install HA without ethernet after making sure that the host system have a WiFi connection?

if he runs HA on 5gHz, it wont “flood” the network(unless he has another bunch of devices that uses 5gHz) , but his Router might get “warm” busy

I don’t know but I’m already flood my WiFi network because HA is connected by cable to google access point. I can’t use a direct access cable to the router. I don’t use HA to manage lights or so on but to monitoring heat pump, PV and home energy consumptions via mqtt (I think a lot of data).
My mini pc (bmax b2 pro) has wifi connection that it worked fine with windows system.
I tried different advices of HA forum but they didn’t work:

  • file my-network with USB
  • nmcli commands
  • ha network update command: wlan0 does not exist.
    I don’t know what I’m wronging.
    Thanks for your advices.