WIFI definitions on HASSIO

I know that there are lot of posts about WIFI setup on HASS.IO, each one propose different ideas, for different versions, and it’s one big mess.
I spent about a week, so far without success.
I was able configured the WIFI on Raspbian without a problem, but HASS.IO seems very special.
Can someone from the developers team or one that succeeded to configure this on same versions, tell what should be done to activate WIFI on RP B+ ?
I’m trying the HASS.IO version 1.13 64 bit.

1 Like

After a week of investigations, connecting pieces of information from WIKI and different forums, i want to share how i managed to find out my problem, which is probably common for lot of users here.
First of all i connected directly to the RP, with display and a keyboard.
Only this way you can fully control your system. Not HASSOS terminal, not SSH.
After system is up, write login, and login as root, without password. Now you are inside the Linux.
Now you can use nmcli to make your WIFI work. But there is another pitfall.
I used nmcli to list all the WIFI networks, but for some reason my home network was not listed.
I found in the INET that channel number 13 is not legal in the US (i’m not living in the US), but the HASSOS, out-of-the-box is probably configured with US country code for the WIFI driver.
In my case, the router was really worked on channel 13 (which was a most clean channel in my area).
I didn’t found how to change the country code, it was much easier to change the RF channel.
After that, my network appeared, and with the same nmcli i managed to connect to it successfully.
The system created entry of NetworkManager with my connection, and from now i connected to WIFI !
Here and Here some help regarding usage of nmcli.
Probably for that reason, the configuration by means of USB storage, didn’t work. I didn’t tried after that.
Hope it will help.

4 Likes

Hi Sashok, I have been trying to solve this same problem for a while now, I don’t come from a software background, how did you write the linux command for the nmcli in the hassos format?, i have try many way with no success

1 Like

@Cristian_Rojas, try this:

  1. after connecting a keyboard and a monitor to the RaspberryPi, hit Enter a few times until you see the login prompt.
  2. type root and hit Enter. You wil be at the hassio > prompt.
  3. type login and hit Enter. You will be at the # prompt.
  4. You can then use the nmcli comand.
2 Likes

Fantastic tutorial at https://tech.borpin.co.uk/2018/10/18/using-nmcli-to-set-a-static-ipv4-address-in-hass-io/

1 Like

Thanks a lot adreups, I have struggle a lot for not writing “login”. now I can finally have an active wifi connection. still not UI but now one step closer

1 Like

I to am having the same problem. I tried the nmcli command but no joy it shows wlan0 disconnected.

When ever I take out the SDcard the my-network file is missing dont reallly know why that is. I use a copy of the sample file and update the ssid and the password. I do not delimit the names with any quotation makes as all the demos I have watched do not indicate that.

From reading the forum I am begining to suspect that the wifi is setup for uk, usually the default when I take a newe pi out of the box and that maybe causing the trouble. is there a way to change this from the command line

by the way I am using the recommended 32 bit image form the installation page

Whatever happens in Raspbian is not the same as HassOS. The default you are used to seeing has nothing to do with the pi itself, but the OS. This is not the cause of the issue you are seeing though.

thanks I figure that out just now I moved the sd card to a known working pi from another project and got the same result. Kind of lost now

@abreups when i type login it asks me for userid and password. I have tried the usual login for the hassio but nothing happens. I have installed hassio container. Is there a default userid and password to get into the OS itself?

Can you clarify this?

What does this mean?

I feel like this was already covered, but HassOS doesn’t have a password. The user is root. If you are not using HassOS, then it doesn’t apply, but rather, you would have your own host OS with it’s own set of credentials.

sorry please ignore, so i have come to learn that when i ssh into hassio.local i takes me right into the OS itself, as root. I was thinking that hassos is containerized so i was trying to reach the host OS itself by typing ‘login’… anyhow long story short i created a user and then used login and it brought me back to the same thing…

I am trying to install wifi but having issues. The following (Guide: Connecting Pi with HassOS to wifi) says to use nmcli command but nmcli command is not found.

No. When you SSH into hassio.local port 22, you’re inside a CONTAINER running alongside home assistant and the supervisor.

No. HassOS is the OS that runs Docker, directly on the hardware. Hassio is a docker CONTAINER.

Your home assistant users have nothing to do with the SSH add-on.

You need to understand that HassOS and HassIO are not the same thing. HassOS is the base OS. If you are using the SSH add-on, you are SSHing into a CONTAINER, not the host OS. I believe if you uncheck a setting in your SSH add-on config (protection mode?) it will allow you to use HOST OS commands.

Thank you for clarifying. I have disabled the protection mode but it still takes me right into the same OS.

It’s not supposed to change the OS…

You realize there are very specific instructions on how to access the host OS right?

They are documented.

Spend a few minutes and familiarize yourself with the documentation

You have to be using the “ssh & web terminal” addon. Not the ssh-core addon.