Wifi issues with Wemos D1 mini V 4.0.0

Anyone else having problems with esphome on Wemos D1 mini V 4.0.0 (with USB-C connector) and connection to Wifi taking 5-10 minutes to connect and showing “auth expired” messages in the logs. They eventually connect without a reboot or re-flash.
Bought a first batch of these V 4.0.0 devices because the previous V 3.1.0 are no longer available. We have 20+ V 3.1.0 devices connected and they all work without any issues and in the same location.

Hi, did you find any solution or explanation to your problems with D1 mini v4.0? I have the same problem, I bought a number of these Wemos D1 mini 4.0 with USB-C connector. They don’t connect to wifi every time they are re-fashed or rebooted.
/Magnus

What WiFi switch and firmware are you running? OpenWRT by any chance?

Does the WiFi signal appear to be weak?, or does it not see any WiFi if you monitor the ESP on bootup using serial?

No, I started using static IPs and the problem went away.
Using multiple 3.0 D1s that are working with my UniFi network (6 APs around the farm) on DHCP. For some reason only the 4.0 devices have problems.

I worked with the Swedish distributor with my case (m.nu). Side-by-side on the desk, the 4.0 device never connected with 100% success while using DHCP but the 3.1.0 did every time.

1 Like

m.nu is where my d1 mini v4.0.0 cards where bought. Static IP did solve my problems. But they are not as stable as my other esp8266 cards.

The Wifi signal is not weak and I’m not using OpenWRT. But maybe there are some router settings messing with my connection. I’m on an asus ax router.

1 Like

I second that comment about stability - they are horrible. I have stopped the using the “D1 mini” version 4.0.0 for the “D1 mini Pro” from m.nu.

I tried a bunch of D1 Mini v4’s from an Aliexpress seller. Similar Wi-fi issues with ESPHome and Tasmota. Mostly as temperature sensors but also with IR senders. My router is an Asus with Merlin firmware (DHCP) but that shouldn’t matter. Constant dropouts, sometimes for hours. I tried various power supplies too. Had better luck with higher-rated Blitzwolf USB plugs but still took a few minutes to come online and would drop out randomly, sometimes coming back online, but very often not.

I can’t even guess what the problem would be, so I’m back to D1 v3s which are now available with USB C plugs.

If the issue can be fixed by using Static IPs, that seems like a problem with the internal logic of the Wi-fi and can’t be fixed by any firmware. Pity. Relying on fixed IP is not a great solution but at least it’s good to know so MAYBE I can salvage them.

We have stopped using the D1 Mini and instead using the D1 Mini Pro version instead.

I have recently experienced wifi/esphome/D1mini HELL for over two weeks. The issue was resolved by rolling back the router/accesspoint firmware on my Asus RT-AX88u hardware from version 388 to the previous version 386. Something in the Asus/Broadcom platform changed, and for the worst. TP-Link wifi devices, Ecobee thermostats, and Amcrest cameras were all affected. It’s definitely the Asus/Broadcom 388 firmware.

I was likely on 386 or older when the issues with the D1 v4’s happened. I’ve been on Asus RT-56U with version Merlin firmware 388.2. Before blaming the firmware, look at the checklist here: Best setup for the Asus RT-AC68U (ACTUALIZED to 2019) | SNBForums

It feels like not using your router’s full potential, but after following this checklist, I’ve had a rock-solid network with more than 50 Wi-fi devices. The router reboots once a week just’ cause but I let it go for 3-4 weeks uptime without issues.

2 Likes

Just today, I began to notice something peculiar. On my Asus router (stock Asus 386 firmware) several of my Wemos D1 Mini ESP8266 devices were appearing with Espressif rather than their assigned DNS node names. This plays havoc with mDNS connectivity and status. ESP32 devices did not appear to have this issue, only ESP8266 devices. Recompiled and reloaded ESPHome firmware OTA where possible, and using ESPHome Loader where necessary. Things appear to be 100% online and stable at the current time. :smiley:

Current ESPHome version 2023.4.4