Wifi logger card abb vsn300 modbus

I have enabled a TCP Client on my WiFi VSN300 wifi logger card that runs on ABB Solar Inverter(Trio) . As far as I understand its supposed to run on SunSpec but no matter what config I try it still doesn’t want to connect to the card. Has anyone in this community have any experience with SunSpec or ABB?

This is now resolved. The solution was in the UNITID which in HA MODBUS plugin translates to Slave parameter. In configuration you need to provide connections params as follows.

modbus:
  - type: tcp
    host: 10.0.0.2
    port: 502
    name: abb

In sensors you need to add a sensor with proper slave id . example :

      -
        name: abb-fgrid-hertz
        hub: abb
        register: 86
        slave: 247
        scale: 0.01
        precision: 1
        data_type: int
        unit_of_measurement: "Hz"

This will allow to access 0x003 function and read holding registers. Would be good to get specifications for the ABB inverters to write up a nice card

HI would you be able to provide some more details of how you were able to get the data polling into Home Assistant. Ive got the same vsn300 card on my solar inverter but just a bit confused as to how to configure it properly. I am not able to see the sensor in lovelace.

I presume you didn’t configure config yet.

I get this message once I try and add in the sensor.

“This entity does not have a unique ID, therefore its settings cannot be managed from the UI”

I have tried to configure config with the following settings:

modbus:
  - type: tcp
    host: 192.168.1.5
    port: 502
    name: abb`

and this I put under sensor:

 - platform: modbus
    registers:
      - name: abb-fgrid-hertz
        hub: abb
        register: 1
        slave: 247
        scale: 0.01
        precision: 1
        data_type: int
        unit_of_measurement: "Hz"`

I would like to retrieve at least two values.

  1. Current Power
  2. Total Power Today

Well , first thing first is that Register : 1 is not Hz. Its something else.

And for power you have to use

    - name: abb-current-power-out
      hub: abb
      unit_of_measurement: "kW"
      register: 84
      scale: 0.001
      precision: 1
      data_type: int
      slave: 247
    - name: abb-lifetime-power
      hub: abb
      unit_of_measurement: "kW"
      register: 94
      count: 2
      scale: 0.001
      precision: 1
      data_type: int
      slave: 247

I presume that bullshit values simply dont register in HA as entitites.
In Lovelace UI you can use following configuration
entity: sensor.abb_current_power_out
graph: line

icon: 'mdi:transmission-tower'
name: Power Out
type: sensor
unit: kW

Hi,
So i tried doing it the way that you advised but the sensors are still coming up as unavailable. Could you post a screenshot of what comes up on your end and how it responds in your Home Assistant lovelace UI. How do we know which register values to pull?

Sorry to hear that. I don’t think screen shots will help you in any way. Snippets I have sent are working with that card. I suppose you already went through steps of checking HA logs to see the modbus plugin errors and also used a Modbus client to try and read holding registers of AbB wifi logger card to eleminate the possibility that it doesnt work at all