Wifi on Raspberry Pi2

I’m trying to install home assistant on an old Raspberry Pi2 of mine, think it’s model B but that’s really irrelevant since no Raspberry Pi2 no matter the model has embedded WiFi chip on it. So I thought about using a WiFi dongle instead.

After trying numerous times with a couple of dongles and some reboots it occurred to me - CAN IT actually work with WiFi via dongle or is it restricted to ethernet cable for networking?

It goes without saying that I have installed the proper Raspberry Pi2 image from your site using Etcher.


Try searching this forum instead:
PS But you might be using HASS.IO then check here:
Optional - Setup the WiFi or static IP: On the SD-card, edit the system-connections/resin-sample file and follow the ResinOS howto/. Check what Dongle is supported.

Also check that you have a proper size power adaptor. The WiFi single add power consumption, with under dimensioned or low quality power adapters that may cause brownouts and reboots.

I have an older RPi that I use for another purpose (retro-gaming system and media server) but I have a wifi dongle hooked up to it and it works perfectly fine with it.

I did find some of the newer dongles don’t work with it (at least a couple i’ve tried) but i finally found one that would work with it.

here is the one I bought:


Thanks for that , the problem is , the dongle I have works with my Raspberry Pi2 in general (I have tried it with Raspbian and with Kodi and works just fine). It just refuses to work with home assistant.


Just install home assistant in a python venv on your raspbian install and the wifi will work just fine. Home Assistant doesn’t care what WiFi device you have.

Then I guess I’m not really sure what you mean by “won’t work with home assistant”?

Home assistant (depending on how it’s installed…) is just an RPi image with a raspbian installation with HA pre-setup in a virtual environment. As far as I know or understand it HA shouldn’t have anything to do with the hardware that will run on the underlying raspbian.

When you say it “won’t work” what exactly are you seeing?

Maybe I came off wrong here , I don’t have Raspbian anymore (or Kodi for that matter) - I ripped both off to install home assistant from the provided image on the main page of the project that comes as a full solution with its own OS

Which installation are you talking about? there are a couple.

Hassbian? Hass.io? other that I’m not thinking of?

I’m talking about Hass.io , my bad I just relised there are a couple. Sorry about that!

what have you done set up the dongle?

If by setup you mean to configure the resin-wifi file then yes!

I don’t use hass.io but a quick search on the googles came up with this:

If you’ve already done all that then I can’t help you much more since I don’t use hass.io.

My only recommendation at that point is to use hassbian. I tried hass.io and didn’t really care for it. Lots more support for raspbian around the net, too.

but then again I could be completely wrong! :grinning:

So use hassbian instead? It’s raspbian with home assistant already installed and running

1 Like

I like how you think! :laughing:

Some of us around here have been fighting this image that home assistant has presented that the only way is hassio. It’s an uphill battle that won’t be won it appears.

Thanks guys I’ll give them a whirl!

But is the Dongle supported by resinos?
Supported Dongles

Thanks for the link, but I don’t know. My dongle is a no-brand random Wifi 802.11 USB dongle and I cannot know if it’s in the list you provided or not. I don’t remember where I bought it from even or when.

I do know though that other distros like Raspbian, Hassbian, Kodi, openelec work with it. Maybe resinOS doesn’t…


I got a solution to the same problem thanks to Geoff. You can view my thread below. But click the link since the solution is further down.