Will not install on a clean OS

I do not understand these - It looks like you have tried everything under the sun… is that the case? Some of those elements you mentioned are not compatible with others. So they (understandably) would not work if/when you mix and match.

At this point, I would recommend we focus on the HAOS install method, and put the other 3 methods aside:
Home Assistant Operating System
Home Assistant Container
Home Assistant Supervised
Home Assistant Core

Now, @trentjw , could you help elaborate your metal box setup? Let’s focus on the hardware first. What do you have?

1 Like

Wow, you are really so thankful to people trying to do something FOR YOU…

1 Like

Been running core for the last year on x86/64 for the last year Intel CPU using debian 11 for the os

Tried to do a clean reinstall and discovered something changed in home assistant install as it now throws the error message that I posted earlier

In post 5 you posted an error message. In response I asked you which stage the error occurred in. You haven’t answered.

Also the question occurs: what version of python is installed on debian?

1 Like

OK. These information should have been in the 1st post, so that people here would know where you come from, and the context.

So which CPU exactly? Make/model of the computer?
Are you running / planning to run anything else on this same metal box?



The first answer also linked to this thread: How to help us help you - or How to ask a good question but sadly that wasn’t taken into account (or read) :frowning:

1 Like
This package requires Rust and Cargo to compile extensions. Install it through the system's package manager or via https://rustup.rs/

Pretty clear huh ?

I had the same on Raspberry Pi OS with the latest HA core built. Install Rust. Problem solved.

1 Like

I got some of the install progress just before the error

Python 3.9.2 if looked at correctly

The error whined about cargo and rust neither solved the issue so apparently the proper steps is where I am failing

I thought so but didn’t work

Yes it does…

Ok then post up the proper steps of when and how to install them because I am apparently doing it wrong

Jesus… Did you even follow the link the error gave you ? There’s literally a step by step guide there…

  • Switch to whatever user you run hass as
  • curl https://sh.rustup.rs -sSf | sh
  • wait
  • try run rustc and cargo from the command line to see if it works - as the user you run hass as.


1 Like

Ok good luck.


Thanks for your help

If I may…

At this point, from the errors and logs and things you have been through, the HA core install method might not be the best method for you.
And if you agree to the above, I’d maintain my recommendations on #17 of this thread.
Now, there are other questions in this threads so far we do not yet have answers for. Let us know when you have the answers, and then we will figure out how to help.

Also. Let’s be civil and stop calling anyone clowns. I mean, it’s certainly OK if you think anyone a clown, but you can always choose to keep it to yourself, control your responses, carefully craft what you actually want to say/ask, so that to stay on topic, isn’t it?


Intel i7, 16 gigs of ram, 256 ssd

Home assistant was the only thing on it

I. Use to run proxmox and have clone copies of different stages of home assistant in case of failure

For the last year been running on bare metal direct

After this failed install I am back into proxmox so I can clone a new test machine more efficiently until I find a path to a successful install

After this failed install I. Tried to. Use haos every download of it was corrupt and fails to write to multiple known USB sticks so I decided to go back to what I am familiar with and muck about until I find a solution

The image then was probably corrupted while you were downloading it. Do you checked the sha256sum or how you have certainty the image file were corrupted? Also which type of storage do you use to save the file? Could be also a corrupted filesystem or drive :thinking:

Wasn’t interested enough in Haos to Pursue yet another headache if it was proper I might have used it until I figure out what broke core

Sigh. Alright. You get this error because some HA core component uses code written in Rust. And it needs a Rust compiler to compile it. And you don’t have that. The latest HA core will not function without a Rust compiler. So you need to install one.

That compiler needs to be available from the user you run hass as. That’s extremely important. Open a console and switch to the user you created for running hass. If you followed the tutorial above, that would be the homeassistant user.

sudo -u homeassistant -H -s

Now try to run the Rust compiler to see if it’s available.


It should say something like this:

if instead it says command not found, then you did not install Rust. Redo the steps I posted above. Do them as the user you run hass on.

Then try to run rustc again, as that user. As long as rustc doesn’t work, HA core will not work.

Edit: oh and yeah I agree, HA core is not the right install method for you. Don’t take that as an offense.

1 Like