Will not install on a clean OS

The instructions on the home assistant for core install returns this error

ERROR: Command errored out with exit status 1: command: /srv/homeassistant/bin/python3 /tmp/tmp2y6lnto1_in_process.py prepare_metadata_for_build_wheel /tmp/tmp9j5uqz0q cwd: /tmp/pip-install-tggqmls5/orjson_23dc88b7bde743e0be1899bf12e147a3 Complete output (11 lines): :boom: maturin failed Caused by: Cargo metadata failed. Does your crate compile with cargo build? Caused by: cargo metadata exited with an error: error: failed to parse manifest at /tmp/pip-install-tggqmls5/orjson_23dc88b7bde743e0be1899bf12e147a3/Cargo.toml

Caused by:
  feature `resolver` is required

  consider adding `cargo-features = ["resolver"]` to the manifest
Error running maturin: Command '['maturin', 'pep517', 'write-dist-info', '--metadata-directory', '/tmp/pip-modern-metadata-4w99emwi', '--interpreter', '/srv/homeassistant/bin/python3']' returned non-zero exit status 1.
Checking for Rust toolchain....
Running `maturin pep517 write-dist-info --metadata-directory /tmp/pip-modern-metadata-4w99emwi --interpreter /srv/homeassistant/bin/python3`

I guess I am the only one with this issue that the instructions on Home assistant no longer is valid for a VM core install

You are here for so long, you surely know this link… :wink:

1 Like

this is the full error that happens on a Clean bare metal install

 Installing build dependencies ... done
  Getting requirements to build wheel ... done
    Preparing wheel metadata ... error
    ERROR: Command errored out with exit status 1:
     command: /usr/bin/python3 /tmp/tmpw8zfxe_q_in_process.py prepare_metadata_f                                                                                                                                                             or_build_wheel /tmp/tmpjnrgu3_3
         cwd: /tmp/pip-install-taa3_2x4/orjson_734f96156b6949fbaf2ecc304355ac9b
    Complete output (6 lines):

    Cargo, the Rust package manager, is not installed or is not on PATH.
    This package requires Rust and Cargo to compile extensions. Install it throu                                                                                                                                                             gh
    the system's package manager or via https://rustup.rs/

    Checking for Rust toolchain....
WARNING: Discarding https://files.pythonhosted.org/packages/ac/4a/43daa65b7ed984                                                                                                                                                             612267983039a58703c48ccbc62561abb43ec7bc8b0663/orjson-3.7.8.tar.gz#sha256=a2e824                                                                                                                                                             220245323bb3291bb10ccf2ba936ed0b14e5e4a6260a1d1ed048caf77e (from https://pypi.or                                                                                                                                                             g/simple/orjson/) (requires-python:>=3.7). Command errored out with exit status                                                                                                                                                              1: /usr/bin/python3 /tmp/tmpw8zfxe_q_in_process.py prepare_metadata_for_build_wh                                                                                                                                                             eel /tmp/tmpjnrgu3_3 Check the logs for full command output.
Collecting homeassistant
  Downloading https://www.piwheels.org/simple/homeassistant/homeassistant-2022.8                                                                                                                                                             .5-py3-none-any.whl (18.5 MB)

What OS are you installing on?

What is a VM core install?

To put it in the correct category, no one changed what you said.

At what step of the install process did this happen?

Computing term that may be apposite: GIGO. Perhaps helping us to help you fell on deaf ears.

1 Like

Well so far I am getting exactly the typical response for asking for help so no worries on that part, par for the course, and then some cryptic references that amount to nothing, then after I flop around like a gut shot squirrel, I stumble across a path that works, then for future reference I will build a step by step tutorial in this case update my current one as something changed, for the next poor sap to have a chance

This is the install I am referring to


Install Home Assistant Core

This is an advanced installation process, and some steps might differ on your system. Considering the nature of this installation type, we assume you can handle subtle differences between this document and the system configuration you are using. When in doubt, please consider one of the other installation methods, as they might be a better fit instead.


This guide assumes that you already have an operating system setup and have installed Python 3.9 (including the package python3-dev) or newer.


Before you start, make sure your system is fully updated, all packages in this guide are installed with apt, if your OS does not have that, look for alternatives.

sudo apt-get update
sudo apt-get upgrade -y



Install the dependencies:

sudo apt-get install -y python3 python3-dev python3-venv python3-pip bluez libffi-dev libssl-dev libjpeg-dev zlib1g-dev autoconf build-essential libopenjp2-7 libtiff5 libturbojpeg0-dev tzdata



The above-listed dependencies might differ or missing, depending on your system or personal use of Home Assistant.


Add an account for Home Assistant Core called homeassistant. Since this account is only for running Home Assistant Core the extra arguments of -rm is added to create a system account and create a home directory. The arguments -G dialout,gpio,i2c adds the user to the dialout, gpio and the i2c group. The first is required for using Z-Wave and Zigbee controllers, while the second is required to communicate with GPIO.

sudo useradd -rm homeassistant -G dialout,gpio,i2c




First we will create a directory for the installation of Home Assistant Core and change the owner to the homeassistant account.

sudo mkdir /srv/homeassistant
sudo chown homeassistant:homeassistant /srv/homeassistant



Next up is to create and change to a virtual environment for Home Assistant Core. This will be done as the homeassistant account.

sudo -u homeassistant -H -s
cd /srv/homeassistant
python3 -m venv .
source bin/activate



Once you have activated the virtual environment (notice the prompt change to (homeassistant) homeassistant@raspberrypi:/srv/homeassistant $) you will need to run the following command to install a required Python package.

python3 -m pip install wheel



Once you have installed the required Python package, it is now time to install Home Assistant Core!

pip3 install homeassistant



Start Home Assistant Core for the first time. This will complete the installation for you, automatically creating the .homeassistant configuration directory in the /home/homeassistant directory, and installing any basic dependencies.




You can now reach your installation via the web interface on http://homeassistant.local:8123.

If this address doesn’t work you may also try http://localhost:8123 or http://X.X.X.X:8123 (replace X.X.X.X with your machines’ IP address).

When you run the hass command for the first time, it will download, install and cache the necessary libraries/dependencies. This procedure may take anywhere between 5 to 10 minutes. During that time, you may get “site cannot be reached” error when accessing the web interface. This will only happen for the first time, and subsequent restarts will be much faster.


Can’t say I understand the blob above. Are you saying you have solved your issue, or not yet? Maybe restructure your sentences would help future users also.

Anyways, you have answered some, but not all of Nick’s questions. The specific answers to each of those question marks are key to a proper resolution.

= = = = =
I have two extra questions:

  • Could you help elaborate a bit more on the metal box / the setup that you plan to run HA?
  • Any specific reason(s) why you wanted to go with this specific install type, to begin with? I mean, how (and why) did you rule out all other install options?
1 Like

Finally. You succeeded to put some background to your question. Congratulations.

Not that I know now, how to help you, but at least, after two days of moaning around I do understand, what you are asking :wink:

1 Like

Maybe @trentjw is using clear OS?

we might never know…

Ok no the issue is not corrected

Is on x86/64 ran both straight debian and raspberry flavor with both bare metal and proxmox just recently tried to do a nice clean reinstall only to find out something changed in the install process

You are welcome, even with this attitude. :wink:

1 Like

And the reason I chose this not that it matters is because years ago it was the only one I could get working, I tried yet again to do the others when this issue showed up and the os image version is corrupt and fails writing to a card and docker never worked for me

Your responses is what earned the attitude so you got the response you Were looking for

This is somewhat confusing. Do you know what operating system you are using? Is it debian? What does the raspberry flavor does in that mix with this bare metal proxmo? :thinking:

I do not understand these - It looks like you have tried everything under the sun… is that the case? Some of those elements you mentioned are not compatible with others. So they (understandably) would not work if/when you mix and match.

At this point, I would recommend we focus on the HAOS install method, and put the other 3 methods aside:
Home Assistant Operating System
Home Assistant Container
Home Assistant Supervised
Home Assistant Core

Now, @trentjw , could you help elaborate your metal box setup? Let’s focus on the hardware first. What do you have?

1 Like

Wow, you are really so thankful to people trying to do something FOR YOU…

1 Like

Been running core for the last year on x86/64 for the last year Intel CPU using debian 11 for the os

Tried to do a clean reinstall and discovered something changed in home assistant install as it now throws the error message that I posted earlier

In post 5 you posted an error message. In response I asked you which stage the error occurred in. You haven’t answered.

Also the question occurs: what version of python is installed on debian?

1 Like

OK. These information should have been in the 1st post, so that people here would know where you come from, and the context.

So which CPU exactly? Make/model of the computer?
Are you running / planning to run anything else on this same metal box?



The first answer also linked to this thread: How to help us help you - or How to ask a good question but sadly that wasn’t taken into account (or read) :frowning:

1 Like