Windows 10 can't access HASSIO through Samba

There is also a registry thing you can try. Don’t have it (I’m on my phone) but try a Google search for "Synology windows 10). The fix you will find can solve your problem :slight_smile:

Thanks my Man. it works. backslash backslash lowercase hassio.\ \hassio.

great

A thing to note though as i’ve recently been dealing with this in work:

As of fall creators update, SMBv2 does not allow guest access by default, meaning if hassio upgrades to this method then most people will have to mess around with group policy or the registry to allow it.

As mentioned above, SMBv1 is now not installed by default and can potentially be uninstalled or disabled during a windows update. SMBv1 is not affected by the recent microsoft changes of disabling connections to samba shares that allow guest logons though.

Guest access in SMB2 disabled by default in Windows 10 Fall Creators Update and Windows Server 2016 version 1709

SMBv1 is not installed by default in Windows 10 Fall Creators Update and Windows Server, version 1709 and later versions

1 Like

thank you for the reply
I tried to do what you said and it sadly didn’t work. I was frustrated at first then I pressed diagnose, it says windows can’t find hassio. check to see if it’s connected to the internet and turned on.

Someone should make a note about this in the Samba add on…

1 Like

Or just supply a username and password when mapping the share.

There is no excuse for using the outdated and insecure SMBv1.

2 Likes

The Samba add on is old and hard to contact

I’m not sure if I’m doing this right as I’m still struggling to get Samba to let me map to my Win10 PC. Are you saying that if I enter values into the username and password fields via the HASSIO Samba config menu I don’t need to enable SMBv1, or are you referring to a separate set of credentials?

I’m talking about the scenario when HA is updated to use SMBv2 or 3.

I had huge problems today with Samba/Win10Pro (for the first time).
This thread helped a lot.
And the final thing that made it works after setting up Samba and Win10Pro, with the following parameters (guest = false with a user name and password), was to restart my router.

SAm2Samb

2 Likes

thx for the reply but still no luck

Same here. Tried every “solution” found on these forums, but still no hass.io share is seen on the PC (Win 10 Pro). Samba works on every other Raspberry Pi in my home network, just not hass.io.

What version of windows 10 are you running?

I’m still on 1709 and these settings sort of work:

I cant see the share under “Network” but I can navigate to it at \\hassio

I am personally not using samba anymore. Configurator has all the stuff you need to edit. You can upload files and edit. If you messed up your configuration, you can use a software called Linux dish internal reader and insert your SD card and open the software and go to resin data

Thanks. As I said, I have Samba working on other Raspberry Pis, a tower PC running Debian Linux and a couple of old CIFS NAS boxes. But, as you said, I don’t really need it in hass.io since I can SSH into it. I can also sftp into hass.io with Filezilla.

i have the same problem use mac / raspberry pi. Was working until about a week ago.

Hi All, I am suffering from the same problem; unable to access the share at hass.io from my Win 10 machines (2).

Tried all suggestions in this thread, but without success.

I installed on a spare sd-card HA with the hand method for Raspberry Pi 3, and installed Samba fronm the commandline and this is working perfectly!!!

It is definately somthing with the samba install in hass.io!
Is there somone from the development team who can shed a light on this issue?

Please, i am new tp HA, but coming from openHAB i am not totally new to home automation.
Please, is there anyone who could help me with this?

You could just NOT use samba?

Use SFTP or get syncthing add-on installed…

[email protected],
Yes i know of this alternatieve, and that does do the job.
But i am used to use Visual Studio Code, and that needs a samba share.
Hope someone has a solution for samba itself

I am not familiair with the syncthing ad-on but i will look into that, thank you for your response.
Kind regards, Bert