Windows 10 can't access HASSIO through Samba

HI all,
I’m new to HA and got HASSIO installed on a pi3. I got homeassistant, SSH-addon and Samba-addon running. I can reach HA through: hassio.local:8123

When i try to connect from Windows 10 to the Hassio icon in the network environment i get an error. The pi3(HASSIO) is detected and i can ping it but windows can;t connect. When i google the problem it looks like a Windows 10 problem. Windows doesnt accept a guest and needs authenticating a user and password. Does anyone know a fix? It already cost me several days searching for a solution. Below the error and my logs. Thanks a lot.

[Window Title]
Network Error
[Main Instruction]
Cannot access \HASSIO
[Content]
Check the spelling of the name. Otherwise, there might be a problem with your network. To try to identify and resolve network problems, click Diagnose.
[V] See details [Diagnose] [Cancel]
[Expanded Information]
Error code: 0x80070035
The network path was not found.
Windows Network Diagnostic found the following issue:
“File and print sharing resource (HASSIO) is online, but isn’t responding to connection attempts.
The remote computer isn’t responding to connections on port 445, possibly due to firewall or security policy settings, or because it might be temporarily unavailable. Windows couldn’t find any problems with the firewall on your computer”

My Samba Options:

{
“workgroup”: “WORKGROUP”,
“name”: “hassio”,
“guest”: true,
“map”: {
“config”: true,
“addons”: true,
“ssl”: false,
“share”: true,
“backup”: true
},
“username”: “”,
“password”: “”,
“interface”: “eth0”

My Samba logs:

starting version 3.2.2
nmbd version 4.6.4 started.
Copyright Andrew Tridgell and the Samba Team 1992-2017
Registered MSG_REQ_POOL_USAGE
Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
added interface eth0 ip=192.168.192.55 bcast=192.168.192.255 netmask=255.255.255.0
making subnet name:192.168.192.55 Broadcast address:192.168.192.255 Subnet mask:255.255.255.0
making subnet name:UNICAST_SUBNET Broadcast address:0.0.0.0 Subnet mask:0.0.0.0
making subnet name:REMOTE_BROADCAST_SUBNET Broadcast address:0.0.0.0 Subnet mask:0.0.0.0
load_lmhosts_file: Can’t open lmhosts file /etc/samba/lmhosts. Error was No such file or directory
STATUS=daemon ‘nmbd’ finished starting up and ready to serve connections
smbd version 4.6.4 started.
Copyright Andrew Tridgell and the Samba Team 1992-2017
Registered MSG_REQ_POOL_USAGE
Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
Processing section "[config]"
Processing section "[addons]"
Processing section "[share]"
Processing section "[backup]"
added interface eth0 ip=192.168.192.55 bcast=192.168.192.255 netmask=255.255.255.0
INFO: Profiling support unavailable in this build.
No builtin backend found, trying to load plugin
Module ‘tdbsam’ loaded
tdb(/var/lib/samba/registry.tdb): tdb_open_ex: could not open file /var/lib/samba/registry.tdb: No such file or directory
tdb(/var/lib/samba/account_policy.tdb): tdb_open_ex: could not open file /var/lib/samba/account_policy.tdb: No such file or directory
account_policy_get: tdb_fetch_uint32_t failed for type 1 (min password length), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 2 (password history), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 3 (user must logon to change password), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 4 (maximum password age), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 5 (minimum password age), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 6 (lockout duration), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 7 (reset count minutes), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 8 (bad lockout attempt), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 9 (disconnect time), returning 0
account_policy_get: tdb_fetch_uint32_t failed for type 10 (refuse machine password change), returning 0
tdbsam_open: Converting version 0.0 database to version 4.0.
tdbsam_convert_backup: updated /var/lib/samba/private/passdb.tdb file.
tdb(/var/lib/samba/winbindd_idmap.tdb): tdb_open_ex: could not open file /var/lib/samba/winbindd_idmap.tdb: No such file or directory
STATUS=daemon ‘smbd’ finished starting up and ready to serve connections
waiting for connections

Try: you localIP:8123. You’re trying to access the file system right?

\\hassio
\\192.168.0.107:8123 (but your IP) This usually works for me.

Thanks @itchaboy for your quick answer.

I allready tried that. Same result and same error.

Hmmm this is just on a raspberry pi and your trying access it on windows 10? Try unisstalling the samba add on and reinstalling it? or did you change any of the settings?

Is something else using port 445? Not sure what your error means…

Address format for samba share is \\ipaddress or \\domain, eg \\hassio or \\192.168.1.xx (your ip though)
Dont use the port at all for file sharing.

1 Like

It seems that Windows 10 is incompattible with the Samba-addon. Does anyone know wich samba version is used in the hassio-addon?
In the new Samba version 4.7 the problem should be resolved. I don’t yet know how to create adddons so hopefully someone here wille update the addon soon. Till then I guess i cant acces Hassio through samba.

1 Like

Have you tried changing your file changing encryption level in Windows 10? Mine was set at 128-bit but setting it to 40 or 50 bit meant that Samba worked.

2 Likes

Thank you this worked for me after trying everything else. 40 bit for Samba :wink:

I know your answer was a while ago but I have the exact same issue but do not know how to change the encryption level. As far as I know I do not have any encryption on my windows.

1 Like

https://www.tenforums.com/tutorials/51024-change-file-sharing-encryption-level-windows-10-a.html. Didn’t work for me though

@Sean_S_Nazarian Me neither. Thanks for the link. I did not realize windows encrypts sharing. Next to try and see if Updating Samba to the latest will work.

1 Like

Same problem. I’m running with Win10 Pro version, and the latest HASS.IO, the samba share addon did not work fine for me. When try to open the shared folder, it stuck for such a long time and failed in opening.

1 Like

I am using MS WIndows 10 Pro to access Samba’s share. I can easily access it by typing: \hassio (that is backslash backslash lowercase hassio).
As soon as it connects to the share it will require authentication. I have set Guest option to False, and specify an Username and Password. Once you have access to the share, then you can proceed to Map a drive letter for easier access in Windows.

Here is my Samba config:
{
“workgroup”: “CYBERNET”, <======My Home Network Workgroup (make sure it matches your case)
“name”: “hassio”,
“guest”: false, <======== Microsoft don’t play nice with Guest access. So set it to False.
“map”: {
“config”: true, <======= I just need access to my config files,
“addons”: false, <====== so I have set the other folders share to False
“ssl”: false,
“share”: false,
“backup”: false
},
“username”: “admin”, <==================Added username
“password”: “@dm!n”, <==================Added password
“interface”: “eth0”
}

5 Likes

Try at map network drive:
–> \your_pi_IP_address\share

2 Likes

You might need to enable SMBv1. Go to Control Panel > Programs and Features > Turn Windows Features on or off > check or uncheck the box for “SMB 1.0/CIFS File Sharing Support”

8 Likes

Do you have Network Discovery turn on in Windows 10?

@ceh fix is the correct fix. Windows 10 in default samba cifs v1 is enabled but if you don’t use this feature at all, it will be disabled automaticly after I while.

Thank you worked a treat :smile:

Thank you!

I also have the same problem and i tried every thing in this page.