Windows 10 Installation


I just installed Python 3.6 a on Win 10 Pro machine
Then I typed the following on the console:

$ pip3 install homeassistant
$ hass --open-ui

But I dont see anything else appear except a localhost on browser with the modules of python etc
I watched the Win 10 video but the speaker went straight into cmd and assumed homeautomation was installed

How do I get things right?

Sorry … I am just a beginner.
Thanks in advance

1 Like

Did you open the browser to http:\\localhost or http:\localhost:8123? The latter is the correct one.

When you click on Python 3.6 Module Docs it defaults to localhost:53509
Its just lists all the modules but there is no Home Assistance page etc

Install the 32 bit version rather than the 64 bit version; I forget what it is but one of the modules doesn’t work right under the 64 bit version. Somethng went wrong in your install somewhere as HA should always respond on port 8123.

You may want to read up on doing it as a Docker install - back when I was running this on Windows, I found out about it after and wished I had done it that way.

Ok I just found under Win 10 apps, the main Python 32 bit version, not the Docs
I then type " pip3 install homeassistant
hass --open-ui

after the >> symbol but its flags incorrect syntax

I have no experience with Docker so I dont think I can take that route :slight_smile:

After you entered the command py -m pip -install homeassistant, did you see something like this on your screen?


You are so helpful!! I am really grateful

Its nearly 2 am here in Singapore so I am going to bed.

Will try it out tomorrow

I think I can see whats wrong. I never did install HA under python.

Will do what you propose and revert if I have any problems

Thanks once again .

1 Like

No problem buddy; that’s what projects like this are all about. Someone helped me, I learned. I’ll help you so you learn and then you can share that knowledge with another new user. You’ll find this a pretty friendly community and no one will fault you for not knowing something. :smiley:

Keep me posted!

1 Like


I just followed what you did and it seemed it successfully installed HA on my C:/users/homeautomation subdirectory .

However, I receive a message that it is “unable to find vcvarsall.bat " and that " You are using pip version 8.1.1 , know however version 8.1.2 is available …” I tried upgrading but it did not work

Also trying to call HA did not work ie using " $ pip3 install homeassistant
$ hass --open-ui " raised a syntax error

I have attached my screen .

How do I proceed now ?

Once you install HA, you don’t have to do it again so the only thing you need to start HA is this line:

hass --open-ui

The other error is referring to a Visual C++ library. You can read about this here; what it is and how to fix it:

hass – open-ui is giving me a syntax error
could it be because I should have installed homeassiatant in the following directory ?


instead of a separate folder elsewhere in my c drive ?

if so shall I just delete the previous homeasistant folder and then

  1. install HA in the above folder

  2. then run hass to open up HA in a browser

Am I right ?


You shouldn’t have to install to any directory - I was never asked for a directory during install. All I did was install Python, run the command:

py -m pip install homeassistant

waited for the installation to complete and made sure there weren’t any errors. When it returned to the prompt, I typed in:

hass --open-ui

and that was it. Watched it start up in the command window for a bit and then minimized the window and opened up a browser and pointed to ( being my windows PC’s IP address). That was really all I did. No extra commands or installing anything. I’m not sure where you are going wrong if you watched that video as it was the same one I watched.

Are you seeing HA start up when you type the command? If not, then your install didn’t complete correctly

Are you keeping the window open or are you closing it? It needs to stay open; if you close the window, you stop HA.

I deleted the pythin setup and reinstalled python and followed EXACTLY what you asked me to do .
But I still get an error ( see the screenshot )

I then went to the video and followed exactly what the video asked me to do ( after deleting and reinstalling python again)

But this time I get the error " access denied "

I am wondering whether it is because of the " red " error messages I received after trying to install HA ( step 1 )

This is the 2nd screenshot

Go here:

and install the Visual C++ Compiler for Python from MS. Then rerun the installer. You won’t have to delete anything as anything the installer finds installed already should list as requirement satisfied.

See if that helps. And you should only have to use the command line from windows command “hass --open-ui” to start up HA, not go into Python at all. I would do this in an ADMINISTRATOR command window by the way, not just as a regular user. RIght click on your start button for the proper link. Also be aware that once you start up HA in this window, it has to stay open! If you close it, HA will close as well.


This is what I did

  1. I installed Visual C++ from the link above

2.I uninstalled python.The version I was using was 3.6 a ( alpha ) so I felt that could be a reason

I installed python 3.5

Now I seemed to have installed HA without problems ( ie no red error messages - unlike previous attempts )

However, the hass command is still not being accepted .

I am feeling a bit foolish now :slight_smile:

I’m starting to run out of ide4as; did you open an administrator command prompt or just a regular one?

It looks like the first time, it saw the hass command, but there was a space between the “–” and the open-ui, so I don’t understand why it didn’t see it the second time when you corrected it. Check and see if you have your path set up like this:

Don’t worry about the NMap line right now, just make sure your paths include the two at the top.

I just managed to do a “successful” Windows install this evening. It ran successfully in that it managed to boot up a browser window for the UI. I think there could be some net discovery issues in that it seems to not find anything (no hues, wemos, media players). I managed to get this far this time (I’ve tried a few times to get a windows install going) by uninstalling my python and reinstalling the 64bit ver.
I think some windows specific troubleshooting videos are in order.

I can not install on a windows 10 and I can not enter to the local ip:8123
i try all from this helps


Has anyone had any luck installing bluetooth on Python for windows 10?

I can’t seem to see anywhere how to do it…

Thanks for any assistance