Windows 10 media player discovery

Everytime I restart HA it discovers my PC as a media player
I don’t want to use my PC as a media server for HA or anything (it’s just an old box that works well enough to provide me with a browser window!) As far as I can tell all the media sharing options in windows and windows media player are switched off.
I just tell HA to ignore this media player which is fine apart from the fact that my core.config_entries file now has over 1500 lines of code relating to this now (and about 100 of useful stuff):

        "entry_id": "94abf945491dcff6c8f8b76068e8baee",
        "version": 1,
        "domain": "dlna_dms",
        "title": "Genie Media Servers (Gerald-HP[Windows])",
        "data": {
          "url": ""
        "options": {},
        "pref_disable_new_entities": false,
        "pref_disable_polling": false,
        "source": "ignore",
        "unique_id": "uuid:34326239-3961-6361-3634-353131366365::urn:schemas-upnp-org:device:MediaServer:1",
        "disabled_by": null

Is there anything I can do to stop this? Can I delete the spurious entries from core.config_entries?

Looks like your media server is generating a completely different unique ID every time it restarts or something.

If you don’t want this to continue, the best course of action I think would be to firewall off any packets coming from that machine’s IP address (note you can’t firewall by destination because it’s going to be a multicast address) to Home Assistant. This should prevent the machine’s DLNA server from becoming discoverable.

you can also completely switch off dlna autodiscovery in HA :wink:

Yah and that might be useful too. However, sometimes you just want to quiet down that one piece of **** machine, while keeping everything else just fine.

1 Like

I think that’s a good plan. I can read how to add autodiscovery but not how to disable it for one topic. Can you give me a hint?
Also can I remove the redundat lines from core_config.entries?

Yeah, if the IP address of the problematic Windows Media Player machine is, you should add an iptables rule to this effect:

iptables -I INPUT 1 -s -j REJECT

The gist of the matter is that you must reject traffic coming from This may vary depending on how your Home Assistant instance is setup. Are you running Core, Supervised, or HASS OS?

Thanks. I’m running HASS OS on Rpi4. Where do I put my iptable ?

Uh oh. No idea. I run HA Core.

Wouldn’t it be easier to stop the dlna server on the w10 machine🤔?
Turn on or off Media Streaming in Windows 10.

It isn’t turned on as far as I can see.
I have Windows Media player installed and maybe that is over-riding the Control Panel options?

Tried stopping the “Windows Media Player Network Sharing Services ”?

it’s somewhere half way😉

It wasn’t started but I have disabled it now:

It’s a real head-scratcher!

1 Like