Winix Purifier C545 integration - run at max speed

We have a Winix Purifier C545, and it is integrated with HACS:

It works great… with one bizarre exception. The unit itself (I don’t think its the integration code, but I could be wrong) does not like to run at max power mode. We run it at the max setting specifically because it creates a perfect white noise for sleeping - so this loudness is a feature.

However, whenever we turn it up to max power, it tries to set itself back to level 3 (4 being the max) and go back to being quiet.

I created an automation that when it is called by Home Assistant to go to level 4, that it waits for 10 seconds (takes time to spin up) selects level 4, then does this two more times. That is, I have an automation that says: Go level 4, wait 10, go level 4, wait 10, go level 4, wait 10. Just to get it to work as white noise. Even then, about 20% of the time, it goes back to being quiet.

If I use the manual buttons on the front, and select level 4, it does not drop back to level 3.

Any suggestions on a better approach? Or is it possibly something in the API communication/integration?

I have a older dumb Winix, right next to my bed, and guess hat setting it’s on for the same reasons…
I just leave it high all the time. Love it!

Fixed! Love this thing too. Solution was to use an automation for the fan:

alias: Keep Bedroom Fan at 100 Percent if on.
description: "Force Winix to stay at full power"
  - platform: numeric_state
      - fan.winix_bedroom
    attribute: percentage
    below: 100
  - condition: device
    device_id: 7521140befffc4a0a1809a58b45fc2d1
    domain: fan
    entity_id: 52e97f84829db7c66653352ebb1124ef
    type: is_on
  - service: fan.set_percentage
    metadata: {}
      percentage: 100
      entity_id: fan.winix_bedroom
mode: single

1 Like

great job on this integration. I just bought 4 of these and this integration already surpasses that of my previous air filters. Wish i could find a kofi link or something to show my appreciation.