Wink configuration issue

I just got my Wink Dev App approved and continued through the Wink configuration in homeassistant. I think I pasted my client id into Home Assistant. It’s stuck at the part where it asks me to click the app link to authorize it, but the link has two spaces in front of my client id (it looks like this: OV). If I fix the link Wink says it’s authorized, but HomeAssistant doesn’t recognize it. I don’t know how to fix this since I can’t seem to rerun the configurator. Is there a way I can fix the client id somewhere in HA configs or is there a way I can force the configurator to start over?
In the meantime I’m using username/password options to access my wink devices.

Hmm interesting. Maybe I should add some code to trim white space at the front and back of the input strings?

Anyway, in your config folder there is a hidden file “.wink.conf” just delete it and the process will start over on the next reboot.

Great! Thank you. I feel silly for not having hidden files shown. I just edited the file and removed the spaces. All good now!

1 Like

There is probably a super obvious answer to this but how can I do this under a setup? Every time I delete the .wink.conf file and reboot it seems to restore itself.

The file gets written when HA shuts down. You need to stop HA then delete the file.

Wow. I am an idiot. Thank you and sorry!

I realize that I’m responding to a year old thread.

I cannot find a way to restore my wink connection. I deleted the .wink.conf, but the wink setup never returned.

Did you delete the .wink.conf while home Assistant was stopped? If you delete it while it is running it will recreate the .wink.conf when you restart

Thank you for the fast response. I deleted the file as you suggested, but still did not get the prompt.

I also noticed my config.yaml did not have a wink: entry. I added one and recieved to add wink prompts.

Just waiting on my dev app to be approved. I had changed the redirect uri. They need to approve it before it will work again.

Thanks again

Did you turn off discovery? Wink will work the first time if discovery is on but without discovery you have to add wink to your config.

You are correct. Discovery is off. Had issues with it pulling sonoff switches before I had them fully configured.