Wireless Watering System - LinkTap

Thanks for your help, I finally figured out the problem.

The LinkTap Gateway and one of my Shelly H&T sensors had ended up on the same IP address.

This is because the Shelly H&T sensors, with a fixed IP address) goes to sleep only wakes up when the temperature/humidity changes, despite being on USB Power (not battery).

This means my Router thinks that address is free whilst off and allows devices to use the fixed IP address via DHCP. When the Shelly H&T wakes up it is on the same IP address and of course all hell breaks loose.

Anyway I have taken the Shelly off of a fixed IP and forced the LinkTap Gateway to a fixed IP so hopefully the router won’t give it to something else!

So, thanks again, if I had not used this integration I would have been none the wiser, the LinkTap App and the LinkTap MQTT Integration didn’t report any issues.

Since I have fixed this, the integration has been rock solid.

No worries glad you got it sorted.
Mqtt messages definitely would have been missed, but its likely you never noticed as when it reconnected it would have picked up the messages and done its thing.

And the mobile app certainly isnt the most responsive thing.

Just getting back to this, when I use the following automation action now it is set to seconds it throws an error when I run it

automation

service: linktap.start_watering
target:
  entity_id: valve.linktap_pots
data:
  seconds: 300

Error

Stopped because an error was encountered at March 8, 2024 at 3:41:17 PM (runtime: 1.19 seconds)

extra keys not allowed @ data[‘seconds’]

Answered my own question, seems this issue was fixed in Version 5.3, I was still on 5.2. It works now.

I prefer to use DHCP reservations on the router. I rarely use Fixed IPs (set on the devices), but if I do, I make sure the fixed IPs that I use are outside the router’s DHCP address range.

Hi
Installed the http api integration
Insert my linktap ip adress

I get a ‘fail to configure’

Maybe i need to setup properly the taplonk hub?

Any advice

Xavier

Hi, can anyone confirm that it works (or not) with ZHA? I have already a full smart home build on that, so it would be massively inconvenient to switch to MQTT.

Thanks and cheers

I don’t think you understand the device. LinkTap is proprietary zigbee. It does not work over ZHA or Zigbee2mqtt. It communicates with a LinkTap hub. Within the hub, there is an MQTT client, which you can setup to communicate with your mqtt server if you have one, and that is how entities and control get in to home assistant. Alternatively, there’s a really nice, local, http integration here that doesn’t require mqtt or anything else. I’ve used both connection methods and they both work very well. The LinkTap system itself is top notch. Its nice to see status and such in Home Assistant, but the LinkTap app is really nice, and once the schedule is set, its all done locally, so its really a set it and forget it type of thing. I love the local Home Assistant integration, but I really wouldn’t miss it if the integration didn’t exist. It would still do everything you need to do.