Wiser Schneider

Is there anybody who work on Wiser Schneider integration into HASS ?

I’m searching for a solution. I saw a json solution for domotics and I know it’s compatible with Zigbee but it appears that it’s not easy to understant the zigbee’s messages.

Ths 4 ur help

I took a quick look at the Schneider site, and it looks like the devices talk to a Schnieder-Wiser Hub via Zigbee. If no hub is used, the phone app communicates via BT. I would think the best bet would be to see if there is an API to talk to the hub.

Which Wiser product? Are you referring to the Drayton Wiser Heat Hub? Or another Wiser product in their portfolio? The Drayton Heat Hub Has a local ALI, and I am using Node Red as an interface.


Thks for you response.

I’m speaking of the EER10200 product by Schneider.
It’s the cross that’s managing boiler and heatings.

The Wiser Heat Hub, TRV and switch integration is available on HACS.
See repository: https://github.com/asantaga/wiserHomeAssistantPlatform

Works really, really well!


Based on the work from asantaga, I’ve created a first version of an integration of the Schneider Wiser Smart controller (the white cross) in Home Assistant.
You can install it using HACS and find the code here:

Happy to get feedback on it.


Your component seems to be very attractive.
I tried to install it but it doesn’t work.

I install it with HACS : OK
I’m searching it now under integrations menu but it’s not appearing.

Have you got an advice to help me please ?
Have you got the code to declare into configuration.yaml to set up manually ?

Thank you for your help and congratulation for your very good job !!!


Thanks for looking into it.
I probably need to update the description since integration page changed quite a lot.

Once installed through HACS make sure you restart HA.
Then in the integration menu search for this:

Hope that works for you.


I’ve restarted HA server but nothing appears into the integrations list.
Then, I’ve rebooted my raspberry to refresh everything and nothing appear to.
I had added the component into HACS and the component is available into HACS.

My home assistant is in french language for your information.

Have you got any advice to help me to get your component working ?

Thank you very much for your help.


In the menu “Configuration” and then “Info” you should get the list of the available integrations on your system.
Could you confirm you have the integration available there? Should look like below:


If this is the case then you need to explicitely add the integration as it needs some configuration information.
Go to the integration menu and click on the “+”

Go down the list.
Then choose the wiser component.
This will open a menu that asks you for some information (IP address of the Wiser system, login and password).

Send me screenshots if needed.


In the menu “Configuration” and then “Info”, the wiser smart component is not listed on my system.

It’s listed onto HACS components and the directory and the files are present into custom_components\wisersmart directory.

I tried to reinstall but the problem is still the same.

You got an idea ?

Which version of the component have you installed ?

Could you send me some screenshots and look in the logs to see if there are some comments?

Have you checked in the integrations list when you try to add one using the “configuration” --> “integrations” page?

Thank you a lot for your help.

A reboot permit to achieve the setup of your module.

It works perfectly now. Your work is awesome.

Thanks a lot for that. You’re amazing !

Cool !
This is good news.
Keep me posted if you have any issue.

If any of you are still interested in using these devices directly as Zigbee devices I have done some work reverse engineering them.

They do in fact have a ZigBee HA Profile mode, but iits a little hidden. I describe it in my github here:

Note: I have initially done my integration for SmartThings, but it could be refactored or used for inspiration towards Home Assistant.

1 Like

I’ve reinstalled my HomeAssistant platform and I’m unfortunatelly unbale to reinstall your wiser component.
It asked me everytime the error as follow :
custom_components/wisersmart/config_flow.py, line 51: self.wiserSmart = wiserSmart(ip, user, password)

Have you got an idea please ?

Thank you a lot for your help !

Best regards


Would you have more information on what you’ve done?
You installed it using HACS, restarted and then configure it using the integration panel?
Which version are you using?



I’ve done exactly what you detailed just before :

  • installed it using HACS : Ok
  • restarted HA : Ok
  • attempt to configure it using the integration panel but it return an error whe i specify IP/login/pawword.

The version deployed is Home Assistant core-2021.5.4 under Synology and Wiser smart component v0.9.5.

Thank you very much for your help !

Could you share all the logs related to the failed configuration of the integration?

Logs like this ?
I don’t know if all these logs are related to wiser component integration…

,2021-06-14 13:18:48 WARNING (MainThread) [homeassistant.util.async_] Detected I/O inside the event loop. This is causing stability issues. Please report issue to the custom component author for wisersmart doing I/O at custom_components/wisersmart/config_flow.py, line 51: self.wiserSmart = wiserSmart(ip, user, password)
,2021-06-14 13:18:48 ERROR (MainThread) [aiohttp.server] Error handling request
,Traceback (most recent call last):
, File “/usr/local/lib/python3.8/site-packages/aiohttp/web_protocol.py”, line 422, in _handle_request
, resp = await self._request_handler(request)
, File “/usr/local/lib/python3.8/site-packages/aiohttp/web_app.py”, line 499, in _handle
, resp = await handler(request)
, File “/usr/local/lib/python3.8/site-packages/aiohttp/web_middlewares.py”, line 119, in impl
, return await handler(request)
, File “/usr/src/homeassistant/homeassistant/components/http/security_filter.py”, line 56, in security_filter_middleware
, return await handler(request)
, File “/usr/src/homeassistant/homeassistant/components/http/request_context.py”, line 18, in request_context_middleware
, return await handler(request)
, File “/usr/src/homeassistant/homeassistant/components/http/ban.py”, line 74, in ban_middleware
, return await handler(request)
, File “/usr/src/homeassistant/homeassistant/components/http/auth.py”, line 135, in auth_middleware
, return await handler(request)
, File “/usr/src/homeassistant/homeassistant/components/http/view.py”, line 131, in handle
, result = await result
, File “/usr/src/homeassistant/homeassistant/components/config/config_entries.py”, line 155, in post
, return await super().post(request, flow_id)
, File “/usr/src/homeassistant/homeassistant/components/http/data_validator.py”, line 63, in wrapper
, result = await method(view, request, *args, **kwargs)
, File “/usr/src/homeassistant/homeassistant/helpers/data_entry_flow.py”, line 109, in post
, result = await self._flow_mgr.async_configure(flow_id, data)
, File “/usr/src/homeassistant/homeassistant/data_entry_flow.py”, line 199, in async_configure
, result = await self._async_handle_step(flow, cur_step[“step_id”], user_input)
, File “/usr/src/homeassistant/homeassistant/data_entry_flow.py”, line 257, in _async_handle_step
, result: FlowResult = await getattr(flow, method)(user_input)
, File “/config/custom_components/wisersmart/config_flow.py”, line 75, in async_step_user
, device = await self._test_connection(
, File “/config/custom_components/wisersmart/config_flow.py”, line 51, in _test_connection
, self.wiserSmart = wiserSmart(ip, user, password)
, File “/usr/local/lib/python3.8/site-packages/wiserSmartAPI/wiserSmart.py”, line 103, in init
, self.refreshData() # Issue first refresh in init
, File “/usr/local/lib/python3.8/site-packages/wiserSmartAPI/wiserSmart.py”, line 169, in refreshData
, self.wiserControllerData = self.sendPostRequest(WISERSMARTSYSTEM, systemData)
, File “/usr/local/lib/python3.8/site-packages/wiserSmartAPI/wiserSmart.py”, line 135, in sendPostRequest
, resp = requests.post(
, File “/usr/local/lib/python3.8/site-packages/requests/api.py”, line 119, in post
, return request(‘post’, url, data=data, json=json, **kwargs)
, File “/usr/local/lib/python3.8/site-packages/requests/api.py”, line 61, in request
, return session.request(method=method, url=url, **kwargs)
, File “/usr/local/lib/python3.8/site-packages/requests/sessions.py”, line 542, in request
, resp = self.send(prep, **send_kwargs)
, File “/usr/local/lib/python3.8/site-packages/requests/sessions.py”, line 655, in send
, r = adapter.send(request, **kwargs)
, File “/usr/local/lib/python3.8/site-packages/requests/adapters.py”, line 439, in send
, resp = conn.urlopen(
, File “/usr/local/lib/python3.8/site-packages/urllib3/connectionpool.py”, line 699, in urlopen
, httplib_response = self._make_request(
, File “/usr/local/lib/python3.8/site-packages/urllib3/connectionpool.py”, line 394, in _make_request
, conn.request(method, url, **httplib_request_kw)
, File “/usr/local/lib/python3.8/site-packages/urllib3/connection.py”, line 234, in request
, super(HTTPConnection, self).request(method, url, body=body, headers=headers)
, File “/usr/local/lib/python3.8/http/client.py”, line 1252, in request
, self._send_request(method, url, body, headers, encode_chunked)
, File “/usr/local/lib/python3.8/http/client.py”, line 1263, in send_request
, self.putrequest(method, url, **skips)
, File “/usr/local/lib/python3.8/site-packages/urllib3/connection.py”, line 214, in putrequest
, return HTTPConnection.putrequest(self, method, url, *args, **kwargs)
, File "/usr/src/homeassistant/homeassistant/util/async
.py", line 151, in protected_loop_func
, check_loop()
, File "/usr/src/homeassistant/homeassistant/util/async
.py", line 140, in check_loop
, raise RuntimeError(
,RuntimeError: I/O must be done in the executor; Use await hass.async_add_executor_job() at custom_components/wisersmart/config_flow.py, line 51: self.wiserSmart = wiserSmart(ip, user, password)