WLAN Config

I have started today with a new hass.io installation on a PI3 model (Use the same PI3 since more than a year with hassbian and everything works fine).

I did adapted the system-connections/resin-sample file and changed ssid and psk. After booting the PI3 is not connecting to my WIFI. I did also added a resin-wifi file like proposed here (https://docs.resin.io/reference/resinOS/network/2.x/#wifi-setup) under system-connections, but no luck eigther.

The PI3 finishes the hass.io installation when I connect it via ethernet, but I need WIFI.

Any hint what the issue could be?

Hello to the group!

I’m having the same issue. I’ve tried the configuration the above poster references. I’ve also tried the headers referenced in the network manager documentation [802-11-wireless] vs [wifi] to no avail. I actually don’t care whether I use WiFi, I just want two networks, one to control HA and one for the IoT devices. VLANs would actually be preferable, as I have a layer 3 switch and can write ACLs. I’m a network engineer and can understand the configurations, it just seems everything is documented correctly, except the one piece I need for it to work. I understand HA is running in a docker VM? but there bust be a way to configure the interfaces. Perhaps I need the more complex version?

Thanks for understanding.


On hassio, HA is running in a docker container. There is no VM.

By default the container is set to run as --net=host which means the docker container has access to the same network as the host. There is nothing special to configure for networking aside from connecting a cable or wifi

Thanks for the reply!
So. When I run an ifconfig, it returns a 172.x.x.x address for etho and the loopback. No mention of wlan0 or the real eth0 address. I’ve tried every iteration of the online instructions in the resin-wifi and resin-ethernet files and nothing gives me a static up. Dhcp reservations work fine, but that’s not what I want. Wireless interface never appears. Do I need to put the files in a different location?

The docker container seems to proxy the MAC address as well, as it’s different than eth0 in ifconfig. Is there good documentation how the network subsystem works? If I understood it better, maybe I could get something working the way I like.

Thanks again

Don’t do this inside the container. That’s not how docker works.

Correct. The container will be bridged to your host. You won’t see the physical devices

This is the root of your problem then.

I don’t know where you put them to begin with. If you’re following Resin-OS guides, it goes where they tell you.

That’s not how it works. It doesn’t matter what the MAC is inside the container.

Gobs of information on Docker website, but essentially there is nothing you need to do INSIDE the container. You don’t need to change any docker configuration. You just need to hook up your Resin-OS network

I found the issue for my WIFI problem.

I had set the 2.4 GHz to channel 13 in my router and that caused the issue.
Since I changed it to “auto” the PI3 uses my wifi-resin file and everything works fine.