Wlan0 connection lost

Hi everyone,

I have HA running in a RPI 4 and I usually update the system without issues. My actual config is:

  • Core 2024.2.0
  • Supervisor 2024.01.1
  • Operating System 11.5
  • Frontend 20240207.0

RPI is connected by cable with the interface end0. Wifi connection is used to access wirelessly to a Huawei Inverter SUN2000. For a long time this configuration has been stable and has worked well.

Last moth I lost the wifi connection and it was impossible to reconect. I reinstall the full system and everything worked again. Four days ago I lost my wifi connection again and I have the same problem again.

I’m trying to reconnect manually using nmcli but I allways have the same response:
Error: Connection activation failed: (7) Secrets were required, but not provided.

If I try to connect to other SSID, it works great and, If I try to connect to the inverter with another device it works too.

Any idea??

Thanks in advance.


have you been able to solve this issue?
I’ve a similar problem with my system.
Zotac intel mini pc with latest home assistant versions. I use the eth0 port for connecting to my router and wlan to connect to my solax Inverter. This setup worked flawlessly for 1 year but sometime around the end of last year it started.
The inverter connection is lost every now and then (2-6 times a week). I can manually reconnect via ui but I don’t understand why the system does not reconnect automatically.
I believe something in my home or surrounding is interfering with my wlan because I sometimes have problems with normal wlan as well but at least all normal clients do reconnect automatically to my router.


Hi There,

Im having the same issues… Dont know how to fix this.
I dont know if there is a inverter problem, or a wifi adapter problem.
Does anyone have any clues?


Hi, same problem with Huawei 2000 model.
Is for sure from Supervisor or HA OS.

Guys, I am not 100% sure why but is fixed for me.
I changed Network adapters (bottom page) from “Autoconfigure” to manual in such a way that only eth0 is checked.

Try it. Good luck!