Wlan0: link is not ready


Brand new to all things Raspberry and HA. I flashed the image for Hass.io and began the installation. It ran for several minutes and the stalled out…

IPv6: ADDCONF (NETDEV_UP): wlan0: link is not ready
brcmfmac: power management disabled

It just repeats these two lines over and over. Thanks.

Exact same situation. Got a new rpi 3B+ last night and flashed hassos_rpi3-2.2.img on a 32GB micro SD Card. Booted up to the web interface with no issues. Then when I clicked on one of the links in the menu, it stalled out with the following messages in the browser on a different machine: ‘Site can’t be reached’ and ‘took too long to respond’. And I see the two messages repeating on the monitor connected to the rpi:

IPv6: ADDCONF (NETDEV_UP): wlan0: link is not ready
brcmfmac: power management disabled


I can’t even get the web interface. I switched to 64 bit for my Pi 3b+ and same problem.

I figured out that I was using old instructions for install (a bit frustrating that instructions dated in July are outdated). Wifi is working (seen on my router) but still no web interface.

I did a reflash and it is working now with a new ip address assigned automatically. I haven’t tried wifi just yet.

I finally got everything up and running, too. Config file was different on the second install, for some strange reason. After I spotted the difference it was smooth sailing (relatively).

I have used the recommended Hass.IO image for RPi3 (32bit) and have the same issue :frowning:

Any advise on how to get it sorted or do I have to re-install a new image ?

I followed this guide for 64bit and lots of trial and error.

The issue is not related to Samba or DuckDNS as I had direct access via keyboard and the issue came up right from the beginning of the install before doing any kind of customization.

I’m not using any IPv6 on my network and Hass.IO works fine … its just a bit annoying that I don’t have a local command login

I tried the 32bit and 64 bit version with the same result … now back on 32bit.

Did you add your SSID via usb thumb drive? Also, clearing cookies helped when I ran into a snag.

FYI: I lost the ability to see my Pi as a network folder somewhere between rebooting and starting up DDNS.

And I also have the same problem, tried three different Pis and network cables. The device gets an IPv4 address from DHCP but refuses to use it, instead continually looping around WLAN.

Looks a lot like my problem.
Tried it on 3 RPI3B+ several image (32bits) downloads and 3 different, new, sd cards.With and without the official Pi PoE hat.
Just neverending loops around:
IPv6 ADDRCONF(NETDEV_UP) wlan0: link is not ready
brcmfmac: power management disabled.
I didn’t thing wlan would be necessary, since it’s powered from a working ethernet interface…

Hi, same thing here.

New Pi 3B+, new 64Go SD and try on an old 3

IPv6 ADDRCONF(NETDEV_UP) wlan0: link is not ready
brcmfmac: power management disabled.

If I setup eth0 same issue.

Try for both 32/64 iso v2.2 same result.
Plugged on 5V/3A btw.

Obs: durring my attempts install doesn’t seem to fail at the same moment, sometimes the install works a long time (with living things in output) sometimes it’s quickier. At the same time community website thrown 504 errors.

I think the problem is with eth0 on RPi3+.
I tried installing it one more time. This time with a USB stick with a configuration file setting the wlan ssid and password, to force it to use wlan and forget eth0 for a while.
IT WORKED! Now i´ve come one step further.
Tried to follow the instructions in the video in an earlier post.
I also installed configuration - ok.
But after installing Samba with parameters saying to use eth0, it didn´t start after reboot! So I´ll run without it for a while.
Seems like it´s an Ethernet problem on RPi3B+.
Experience: I took bakups of the MicroSD after each major step. Took some time, but definitely worth it.
Note: When you make the configuration file on a windows pc, make sure it´s saved with Unix-style line endings (LF, not CR LF). This can be selected in most good text editors (Notepad++, Textpad etc).
NOW it´s time to go forward and get all my z-wave devices up and running. And some zigbees.


To avoid the wlan issue I try to use eth0 instead, with both non/static ip.

Into an USB Stick named ‘CONFIG’ I put the file ‘network\system-connections’ with folloqing config:




On first boot:

and then arrives the:

[   353.549156] IPv6: ADDRCONF(NETDEV_UP): Wlan0: link is not ready
[   353.563428] brcmfmac: power management disabled

After several secounds both lines are printed again and again with http://hassio.local:8123/ responding ERR_CONNECTION_REFUSED

When I login with root and type:

hassio > ne info

I got:

Error decoding json invalid character ':' after top-level value: 404: not found

Issue on tracket

I had the same problem during the install with the Hass.oi installation on Raspeberry Pi 3 B+. First on the 64 bit version and also on the 32 bit version. But found the solution for the 32 bit version:

  1. Etch the hass.io on the SD cable
  2. Install the SD card, connect the ethernet cable. No need to connect the HDMI since the monitor is not needed for the install
  3. Power the Pi and wait about an hour
  4. On your laptop and using Firefox type the following:

Problem solved with the 32 bit version. Now I am going to test the 64 bit version

Thanks for your solution but I would like to complete the installation using the WiFi . I followed the steps mentioned above on my new Rasp 3 B+ on a 32 bit version and get this message repeated:

Pv6 ADDRCONF(NETDEV_UP) wlan0: link is not ready
brcmfmac: power management disabled.

My USB matches the one listed above and I created it under the network directory. My USB Was formatted in FAT32 labeled CONFIG.

Any clues?

i am curious if someone has a different solution for this problem. i tried loading from file. i even tried the solution from Ruimatos with firefox but the thing is on my pi the webpage never gets started.

my pi worked fine got it setup and it worked for a week then i did something wrong i must emit.
but now im looking at the same problem as any of you guys hassio starts fine but for some reason is not able to start configuration because of the wlan0: link not ready

I’m following this thread for a while now, as I’m having the same problems. I discovered that “hassio” is connected to my router, but still the added display says:

IPv6 wlan0: link is not ready
power management disabled

I’m trying to leave the Raspberry on during the night to see if that has any effect.