Wled integration keeps losing connection

Hello,

I installed the Wled integration with the latest HomeAssistant version.

Home Assistant : 2022.7.5
Wled : 0.13.1

The problem is that the connection to WLED keeps getting lost, unfortunately you can’t see much in the logs, but in the small log window under Devices → Wled you can see it if you send a command for a playlist, for example, the entity Firmware constantly changes to unknown, then it takes a few seconds or 1-2 minutes and it updates itself again to “current”.

This shows very well that he loses the connection, the whole thing happens over and over again, especially if you send commands quickly, like I do, for example, every 10 seconds.

You can also reproduce this very well by simply switching the leds in HA ON/OFF one after the other

I use the playlist commands in an automation and when the command is executed in HA nothing happens, but when I switch to the WLed UI I can control everything, so it must be the WLed integration.

If I can help in any way, I’d be happy to do so, but unfortunately it’s useless

the problem is stll there

1 Like

I have the same issue. Did you find solution for this?

same issue here

Once I created Preset in wled interface with all needed segments, everything works fine. Then I can controll segments as needed.

There’s no solution for this issue. WLED simply can’t handle HA’s massive amount of API calls in a short time. Personally, I disable all update entities because they are too aggressive, which reduces the chance of this happening.

Outside the update entities, WLED will still run into these issues if you send too many commands at once. It doesn’t seem like anyone at WLED is interested in making the JSON API avoid this issue, so the solution I use is to make a series of presets. The other option would be to create your own WLED calls using the JSON api, but focus on building the JSON yourself so that you use 1 call to perform ALL actions. I.e. set all segments at once, etc.

If you don’t have multiple segments and you’re just turning on a single strip with a single effect and preset, you won’t have any of these issues.

2 Likes

i get succes when i ping my WLED devices thru HA, i dont now why but since July it works well

## PING TREPPEN WLED
## ESP2866 Treppe 1
  - platform: ping
    host: 192.168.0.77
    name: "ping stair 1"
    count: 5
    scan_interval: 30
1 Like

Wled integration is causing lag on esp, disable it and reboot is the only solution to get rid of ~10s interval lag. Any possible fix ?

I disabled some entitites in the integration and now same pronlem appear. I have to reload the integration, it works some minutes and fails again

I just added a ping in the cong yaml and now it works well but still unknown firmware as soon as I change a setting. Thanks for the workaround :slight_smile:

But ping is soon to be depreciated! What then?

Ping isn’t deprecated, configuring ping via YAML is. Configure it via the UI.

This is the exact same setup as lulu (Via the UI)

image

image