WLED timeout errors

I’m using HA Core 0.108.2 with WLED integration and into the HA log file I have a lot of errors like this:

ERROR (MainThread) [homeassistant.components.wled] Error fetching wled data: Invalid response from API: Timeout occurred while connecting to WLED device.

The WLED Wifi signal sensor reports about 45% and sometime the WLED elements becomes unavailable.

Do you have any WLED timeout errors into your logfile?

I have exactly the same error, thousands of times over the last couple of days.

The only way this has been reported to have been fixed is to delete the WLED integration before upgrading to 0.108 then reinstall it. That may mean you have to downgrade to 0.107 first. Simply reinstalling WLED while on 0.108 does not seem to work. See:

1 Like

It still works without an issue after a day.

  1. Go back to 107
  2. Remove Wled integration
  3. Update to 108
  4. Install Wled integration.
1 Like

update, after this method, you can remove and reinstall in 108 and it will work.
BUT, whenever I restart HA (or loose WIFI signal, restart router etc), it has a high chance that it will bug again, and I have to remove and reinstall the integration to fix this, so it is buggy, and something is wrong with the 108 update :\

@BullFrog Yes I get same issue after the suggested method.
Moreover I analyzed the configuration of WLED device with native web interface and also if I’m using API integration, I noted that there was configured MQTT protocol with some strange parameters (I’m sure that I never set them). I disabled MQTT section into WLED configuration and restart WLED device. Now there is no error into HA log since five hours.

UPDATE: I’ve again timeout errors into the HA logfile.

did anyone get an answer on how to solve this? I tried to downgrade to my 108.9 , remove the WLED integration and then upgrade to 109.1 and integrate WLED but I still get these errors:
homeassistant.components.wled] Error communicating with API: Timeout occurred while connecting to WLED device.

Same issue, would love to find a solution. I still have full access to WLED via the web interface, but for some reason HA keeps generating timeout errors.

You should all contribute any meaningful information (logs, physical set up etc…) to this issue:

I know this is an old thread but I was digging into this and I found this problem when my WLED is connected via mesh repeater.
When connected to the router, error disappeared.
I am using a 1750E mesh repeater with a 3490 FritzBox.
Maybe, this is the case ?

i experienced the same issue with another mesh repeater, any idea to solve this? it’s very annoying