Wood’s Air Conditioner through Alexa or Google home?

So I just bought this AC and now I want to integrate it into Hassio. At the moment I control it either through a remote or the app on my phone.

The product is advertised as compatible with both Google Assistant and Alexa. Now, I don’t use either of those, so my experience is very limited here. From my understanding though I need additional hardware to use either of these two services (?) and that seems inefficient to just use one product.

Any input, ideas, thoughts or witchcrafts to make this happen? Can I install some kind of virtual software in Hassio to use that as a kind of middleman to control the AC?

Most remotes can be emulated in home assistant, so that’ll be easiest.

Second you could reverse engineer the app by using Packet capture (it’s an Android app)

Anyone had any luck on this?

I ended up getting a BroadLink RM4 and emulating the remote.

I first tried integrating it with Home Assistant through Google Assistant, but the only option available with that was to turn it on or off.

I MITMed the app, and it is clearly a white-labeled Tuya app.

Unfortunately they use the new encrypted Tuya API where the localkey isn’t findable. This might work though, but I frankly find it really confusing.

I also just got the above mentioned Wood’s Cortina Smart Home.
I was surprised, that so far no Home Assistant integration is available (so far) that is using the native API of the device via WiFi…

Has anybody been able to integrate it on any Smart Home platform, Python, …?

(Note: My plan b is using the my Broadlink IR. But I’d like to avoid this…)

Hey! I just bought the Cortina wifi version and had problems getting it to connect with my wifi via the Woods connect app. I called the support here in Sweden and they told me to pair it with the Tuya app instead and that worked like a charm. It now shows up in HA via the Tuya integration and I can turn it on/off, set temperature and adjust fan level to either hight or low.

3 Likes

Solved! Thank you so much for taking the time to spread the word about this. After switching over to the Tuya integration and app I can now control my AC through Home Assistant :slight_smile:

1 Like

Hey, could you please explain the general steps you took, did you use localtuya or tuya, etc? :slight_smile:

I have to admit, I dont know what localtuya is, or what the difference is between that and the app I used.

I just used Tuya Smart-app from the appstore. Reset AC and paired it with the app. I do remember the pairing process being kind of weird. The AC can only be paired for like a couple minutes once powered on, so I had to unplug and replug a bunch of times if I remember correctly.

Where in the process are you running into trouble?

The pairing process is being a real pain in the ÆÆÆ ngl :smiley:

Edit: Can’t even get it to pair with the woods app rn :weary:

Edit2: It worked in the end :skull: But now I’m stuck in Hassio for the Tuya integration (not localtuya)

I remember having issues like that too. Even with the native Woods app. You kind of just have to repeat the process until it works. Glad to hear you got it working in the end :slight_smile:

Interesting thread.

I have the very same issue with my Cortina Silent 12K Smart Home. Worked like a charm last summer but since then, we’ve changed the WiFi password and now I can’t get the AC to connect to our WiFi again.

I learned the only way to let the AC know of a new WiFi password is by removing the device from the Woods app and then re-add it. This is where the problem is, no matter what I do, it’s not found by the app anymore.

I’ve tried deleting the app and reinstalled it, I’ve disabled the 5GHz and I also tried the Tuya app but same thing - the AC can’t be found. Not fully sure though what device you should pick in the Tuya app since I couldn’t find an exact match. As I recall it, the closest match I could find was called something like ‘Portable AC’.

Today, I was on the phone with Woods support and they told me they will send me a new WiFi card. Will then try to replace the existing one and hopefully, it’s not too difficult. According to the guy I spoke to at Woods, he said I only need to take the front off by unscrewing 3 screws at the bottom of the AC and then there should be a plastic box seen. Under this box is where the WiFi card is located I was informed.

Let’s see how it goes. Quite annoying to say the least when you can’t operate the AC via the app nor via Google Assistant.

How did you reset the AC?

I’ve been trying to find information on how to perform a reset but to no avail. The only thing I’ve found is how to put it in pairing mode by holding the Timer button on the panel of the AC for 5 seconds until the WiFi icon in the display starts blinking rapidly.

Maybe this is why I haven’t been able to readd the device, because I need to reset it first…