[Workaround] Evohome multiple concurrent locations

Had the “not found” error since updating to 2023.12.
So I came back here reading up again, and I sure am impressed with the amount of work you put in support, David!

So I followed the wiki, using Putty as an external ssh program, but the error persisted. Deleted everything under custom_components (I only have this one), and tried again, but with the terminal&ssh addon from within HA (Open WebUI). The difference is then that the config directory is actually in the same location as is described in the wiki (“/config/”), where the location through Putty is “/usr/share/hassio/homeassistant/”. And of course, directly through the HA terminal Add-On, you have root privileges. But after repeating the wiki steps litterally in the HA terminal, I still got the not found error. But now I also got a warning “incompatible system. Upgrades impossible” or something similar. Had to do with systemd not being installed, which is weird. Tried a couple of things to fix that unrelated error, ultimately re-fetching and installing HomeAssistant Supervised … which worked like a charm! I did not even need the backups I made! HA was up and running again. So Now I could try a third time to add my second location (the location_idx 0 kept working all the time). This time through Putty again, because that works a lot quicker and easier than the HA terminal&ssh add-on. But I promoted myself to root first (“sudo su -”), and that seemed to do the trick.

So no extra work for you, David; I just though I’d leave it here for others that might be struggeling with the same access rights issue that effectively hides the custom_components (sub-)folder(s) from the homeassistant (root) user.
Or maybe just a note on that “issue these commands as root user” in the wiki, but that’s all.

@all I did see that in HA 2024.7 the const.py file is changed so I was wondering does the WIKI for multiple locations still applies and works and how should this file now look, because in WIKI still is showing the old file when putting command to check if changes where applied to files.

I am referring to step 4 and 5 of the WIKI


I assume now Domain: Final" should be evohome_1?

I also raised a issue on github asking same