Working on HomeKit Docker MAC workaround

Tags: #<Tag:0x00007f32607abba8> #<Tag:0x00007f32607ab978>

Hi guys,

I’m quite new to the whole home-assistant running in docker for Mac thing…

I figured out that het HomeKit component dousn’t function on the Home-assistant on docker for Mac installation due to how docker for Mac is constructed… (docker environment is as I understand a Virtual Machine on its own) due to this and the restrictions on network interfacing trough this VM to the Mac environment the —net=host command dousn’t function because that links to the VM network in between docker and the Mac host.

I’m trying to get my head around this problem and try to figure out a solution. So any thoughts or feedback are more than welcome!

The thoughts running in my head at the moment are to use the VPN passtrough to let the docker environment connect to a VPN socket on my Sophos UTM and let it join my main automation network from there.

This so HomeKit and the auto discovery are directly looking in the Automation network environment.

Call me crazy :stuck_out_tongue_closed_eyes: i’m definitely not an expert on this matter so please any feedback or thoughts are more then welcome!

I running to the same problem, also for Nmap (network scan) and for USB devices like zwave controller. For zwave I switched to a VeraEdge as hub, who also can readout my DSMR.

It’s an issue with docker on mac, also for the Hue component if I remember correctly. I’m running docker in a virtual machine on mac to overcome this problem. Seems like an overkill but it works and is very stable.

My Hue is working fine here and also VeraEdge is through LAN and working fine.

That is why i wrote “if I remember correctly” :wink: Anyway there was a component I’m using which needed the network: host option which is not available on docker for mac.

1 Like

bumping this - anyone solved it yet?

I might revert back to homebridge for that functionality but it’d be nice to have it on HASS.

@weissblut, i fixed iT for me in an other way… I switched to running hass.io in an virtual box. Brought some additional advantages with it. Down side is the “free” virtual box software doesn’t like the virtual interfaces of my mac… ended up making 2 finical connections and even some console network commanding in hass.io to get it to work… everything within works great and stable fore me since then!

Hit me with a reply if you want some more info

Kind regards,

Rosiaantje

Thanks for that! I might try that, even tho I’ve to say the docker part is working really well apart from this network issue for Homekit.

What kind of issues did you meet when using hass.io on VBox on Mac?

Thanks!

The “special” thing was that I wanted HA to be connected to my main network and my automation network. Both in their own vlan. Had to make 2 entries in the nmcli of the hass. But have to say it was not that hard. Other thing is that vlan interfaces were not rightly picked up by virtual box so I made two untagged fisical connections. Everything else went as a breeze… drzzz has an video about it.

One of the advantages in my opinion is that you have the option to take snapshots so it’s an extra layer of disaster recovery.

Need to ad that all functions I tested are working normally. All other things are the same ass off docker vs rasp

Hi, I installed hassio via Virtualbox on an i7 mac mini last night, and I’m not being able to expose home assistant devices to homekit anymore. Anything in particular you think i might have missed?

Hi @mikalmo, how did you configure network on the VBOX setup? Did you change anything in the hass network config?

Hi, @Rosiaantje! I figured it out, finally. As it turned out i had failed to include the “/24” behind the static ip I set initially.

Bumping this. It has now been more than 2 years, maybe someone has a solution for running HA (core) on docker on MacOS? Assuming I don’t want to introduce another VM in the mix.