Working RPi4 Bluetooth adapter but no discovered devices

I’ve read through a handful of other threads about this and have not seen a concrete solution – I have a RPi4B with a correctly-discovered bluetooth adapter. When I run bluetoothctl via terminal, I see output indicating that it’s discovering supported devices. But none of these devices appear as autodiscovered, and even when I try to explicitly add a device with an integration (e.g. Aranet4), it says, “no unconfigured devices found.”


Any ideas?

Open GH issues which seem to mirror what I’m seeing:

EDIT: One other data point I discovered was that plugging in a (supported - Plugable USB-BT4LE (BCM20702A0)) external BT dongle resulted in device discovery working. Except pairing is failing with the first device I’ve tried (though it’s a custom entity – Ember Ceramic Mug):

Retrying setup: An error occurred updating mug: e=BleakDBusError('org.bluez.Error.NotPermitted', 'Not paired')

EDIT2: Latter issue was USB port interference – dongle + extension cable worked. But I’m still wondering why the RPi built-in BT radio doesn’t discover devices at all.