Would love some help getting data from my smart meater!

Maybe someone can help me out that has done this, i am a bit stuck…, been doing a lot of googling and im almost there, @adamg, @mladem ?? Anyone?

Anyways, i can successfully start my rtl_str in raspberry pi and it is listening on the frequency that i belive is my gas meter (according to a quick google search that someone made)

I had a heck of a time installing go, but finally did and downloaded https://github.com/bemasher/rtlamr, however i do not know the life of me how to start it…, it says its as simple as the following but it does not work

Usage

See the wiki page Configuration for details on configuring rtlamr.

Running the receiver is as simple as starting an rtl_tcp instance and then starting the receiver:

# Terminal A $ rtl_tcp 

03%20PM

# Terminal B $ rtlamr  

this is my variables for go

export GOBIN="$HOME/projects//bin"
export GOPATH="$HOME/projects/src/"
export GOROOT="/usr/local/go"

but if i run something like, this, i get an error no such file or directory


[email protected]:~$ ~/projects/src/src/github.com/bemasher/rtlamr -msgtype=idm --format=json --filterid=XXXXXXX --single=true

-bash: /home/david/projects/src/src/github.com/bemasher/rtlamr: Is a directory

[email protected]:~$

I also found this, so i also know how it’s being decoded: https://web.stanford.edu/class/ee26n/Assignments/Assignment6.html

1 Like

somewhere i think the amr was installed wierdly, but now i get this after reboot:

rtl_tcp: symbol lookup error: rtl_tcp: undefined symbol: rtlsdr_set_bias_tee

Hi David. I am no expert in golang, so I do not know about those errors. But I will try to help you with this. What version of golang are you using?

My biggest issue was getting golang to install properly, but once I did it worked good. While I was installing I made some notes so I did not forget stuff. You can see below and compare it to your procedure.

[email protected] ~ $ sudo apt-get update
[email protected] ~ $ sudo apt-get upgrade
[email protected] ~ $ sudo apt-get install python-pip python-dev build-essential
[email protected]errypi ~ $ cat <<EOF >no-rtl.conf
blacklist dvb_usb_rtl28xxu
blacklist rtl2832
blacklist rtl2830
EOF
[email protected] ~ $ sudo mv no-rtl.conf /etc/modprobe.d/
[email protected] ~ $ sudo apt-get install git-core
[email protected] ~ $ sudo apt-get install git
[email protected] ~ $ sudo apt-get install cmake
[email protected] ~ $ sudo apt-get install libusb-1.0-0-dev
[email protected] ~ $ git clone git://git.osmocom.org/rtl-sdr.git
[email protected] ~ $ cd rtl-sdr/
[email protected] ~/rtl-sdr $ mkdir build
[email protected] ~/rtl-sdr $ cd build
[email protected] ~/rtl-sdr/build $ cmake ../
[email protected] ~/rtl-sdr/build $ cmake ../ -DINSTALL_UDEV_RULES=ON -DDETACH_KERNEL_DRIVER=ON
[email protected] ~/rtl-sdr/build $ make
[email protected] ~/rtl-sdr/build $ sudo make install
[email protected] ~/rtl-sdr/build $ sudo ldconfig
[email protected] ~/rtl-sdr/build $ cd ~
[email protected] ~ $ sudo cp ./rtl-sdr/rtl-sdr.rules /etc/udev/rules.d/
[email protected] ~ $ sudo reboot
[email protected] ~ $ rtl_test
[email protected] ~ $ wget https://storage.googleapis.com/golang/go1.11.1.linux-armv6l.tar.gz
[email protected] ~ $ sudo tar -C /usr/local -xvf go1.11.1.linux-armv6l.tar.gz
[email protected] ~ $ cat >> ~/.bashrc << 'EOF'
[email protected] ~ $ export GOPATH=$HOME/go
[email protected] ~ $ export PATH=/usr/local/go/bin:$PATH:$GOPATH/bin
[email protected] ~ $ source ~/.bashrccmale
[email protected] ~ $ go get github.com/bemasher/rtlamr
[email protected] ~ $ sudo reboot

In one terminal I run simply “rtl_tcp” in the root directory. In another terminal I run simply “rtlamr” again in the root directory.

thank you, after googling and seeing how someone else started the go script, i got it working (wrong path crap), anyways, i tried chaning the centerfreq so that it could listen on a frequency i believe works with PGE, and nothing yet, but according to their website, it only send’s out data once a day…

I got a nortek HUSBZB-1 and it should read the smart meter from PG&E, but I can’t find the MAC address of my USB device to pair with the meter!

You can find the “stream my data” info on your PG&E account page.

Any thoughts?

Thanks!