WPA_Supplicant - Squares instead of “ - absolutely stumped

Hi Community.

I’m stumped, I’ve been struggling with home assistant for months. I’ve been using the “Hassbian on a pi zero w in 39 minutes” tutorial.

I think I found my problem. When editing my wpa_supplicant.conf with Atom (and notepad) on Mac OSX, I’ve just noticed that I’m getting a square instead of the “ around my wifi details.

No wonder Hassbian isn’t doing its installation, the WPA details aren’t correct!

Does anyone know how to edit WPA supplicant correctly on a Mac, and avoid the squares? I can use the sudo nano etc to edit the file, but by then it has booted without wifi and I have to force an install which always has components fail.

Is this an OS issue? Is there a way to edit the .conf file on a Mac that doesn’t leave me with squares instead of “ around my wifi details?

Thank you

If you look at your post, every time you have put a quote mark they are ‘posh’, in that they are angled inwards towards the words you are quoting.

You need to find whatever settings in your text editor/OS/wherever to just use normal, straight quote marks for this file, and pretty much anywhere else that isn’t a printed document.

Yours (copied from your post): “Hassbian on a pi zero w in 39 minutes”

What it should be: "Hassbian on a pi zero w in 39 minutes"

Note that in the second one the quotes at both ends are pointing straight down, but on yours they’re facing in?

Unfortunately I can’t tell you where these settings will be on your device, but hopefully now you can see the problem you can work it out :+1:

1 Like

You solution is in the photo you’ve posted.
Use nano to edit the file.

Thanks mate that worked