Wrong colours after Tuya converted (tasmota) - "Globe" RGBW Smart bulb

Hello everyone, I purchase a 3-pack of RGBW smart bulbs from costco.ca for 30$. I knew they were tuya bulbs so I thought that they were going to be very easy to add to HA.

Even though I set them up with the Tuya app, they didn’t show up in HA.
Long story short, I converted them, and they are now running tasmota.

The “module” that worked best for me was "Arilux LC11 (38)
From the tasmota web UI I was able to get the bulb to work with:
-on/off works
-Brightness works

However, the Cold/Warm seemed off.

I continued with the HA configuration…
To setup the MQTT I follwed this: https://github.com/digiblur/Sonoff-Tasmota/wiki/Smart-Bulbs

I first tried the RGBWW (5 channel) but that didn’t work.

the RGBW (4 channel) works best, it works just like the tasmota web gui.

Blue = Blue
Green = Red
Red = White

when adjusting the cold/warm
warmest = green
Coolest = warm (orange)

So how do I fix this?
I’m very close… but I don’t know how to change the color channels.

Does anyone know how I can fix this?

Normally in a sketch you would have an option to change RGB to GBR or GRB etc, if your using a pre-compiled firmware then it maybe listen on the GitHub or website, how to change it.

For ESPHome you just put it in the config file, Tasmota I think you set it in the command part in the devices webpage after you have flashed it.

SetOption37

1 Like

Thank you! that really pointed me in the right direction.

despite your help … my issue persist.
no matter what option I enter in the console, nothing changes.

While on the page you sent, looking the wiki I found a “template repository” - and I actually found my bulb!
https://blakadder.github.io/templates/globe_37726.html

But again… I select it, save, reboot device… nothing changes.

What am I doing wrong?

Did you get this working. I just bought the same and it worked fine.
Then I switched it to ESPhome, which was even better.

I’ve flashed the tasomta firmware but I’m curious about esphome. Is there a specific configuration required for the globe bulbs mentioned above?

Yes, you can transcribe the tasmota template to create this

esphome:
  name: globergb
  platform: ESP8266
  board: esp01_1m
  esp8266_restore_from_flash: true

# based on https://forums.redflagdeals.com/costco-globe-wifi-smart-bulbs-3-pack-29-99-2289331/7/ 
#https://blakadder.github.io/templates/globe_37726.html

wifi:
  power_save_mode: none
  networks:
    - ssid: "yours"
      password: "yours"

# bulb ip
sensor:

# Enable logging
logger:

# Enable Home Assistant API
api:

ota:

output:
- platform: esp8266_pwm
  id: output_green
  pin: GPIO12

- platform: esp8266_pwm
  id: output_red
  pin: GPIO4

- platform: esp8266_pwm
  id: output_blue
  pin: GPIO14

- platform: esp8266_pwm
  id: output_wwhite
  pin: GPIO13
  max_power: 0.65

- platform: esp8266_pwm
  id: output_cwhite
  pin: GPIO5
  max_power: 0.65

light:
- platform: rgbww
  name: "globergb"
  id: light_rgb
  red: output_red
  green: output_green
  blue: output_blue
  cold_white: output_cwhite
  warm_white: output_wwhite
  cold_white_color_temperature: 5000 K
  warm_white_color_temperature: 2000 K
  effects:
  - strobe:
  - flicker:
  - random:

Just out of interest, what do you find better with ESPHome vs Tasmota?

I’m running Tasmota on a few devices (Sonoff RF hub, S26 plug, soon a 4ch Pro), so I just stuck with Tasmota for my bulb too.

Any particular reasons you found it worthwhile switching? Thanks!

I’m having some issues in HA with Teckin SB51 RGBW bulbs using Tasmota. The Tasmota template and MQTT configurations work fine, it shows up in HA no problem and I can adjust the RGB colours and white level in the UI My problem is using Alexa as I cannot ask Alexa to select white/cool white/warm white/natural white s not supported so asking for white only selects the RGB blended white which is lilac at best and dull. I’ve tried everything including considering an automation or script to select the white through an MQTT publish but that is beyond my skills. I’m considering using ESPHome and will start with your code. Any other ideas on enabling white through Alexa?

I just fixed my own query! Enabling the HUE Bridge setting on the bulb and allowing Alexa to discover this device instead of the HA entity has given me all the white colour temperature options and asking for white selects the white led’s.

I run tons of stuff with ESPhome so I guess I’m just used to the system and familiar with how it can work for me. I feel like it has a lot more flexibility - and feels like a natural extension of the Homeassistant ecosystem since configuration is done with YAML. Tasmota feels like black box by comparison.

I have the same issues but with google assistant, sounds like a good fix you found.

I know thread a bit old but for those that recently flashed their tuya/smart life bulb with tasmota, this are the steps you can take.

Once you flash tasmota onto the device, the device doesn’t know what it is anymore, so you have to configure it. We know they are using ESP chips (hence you could flash it) but you might not know the pin configuration.

If you are trying to set up a regular RGBW bulb, you are looking for the 4 pins that control the light color. So log in to you tasmota device via web interface, go to configure module, then select the last one “generic 18”. Device will reboot, then go back to configure module. Now you will set ONLY one of the GIOP at a time with PMW1. IE, GPIO1 you set it to PMW1 and save. Device will reboot, and on the main screen you will have a toggle and a slider. If toggle doesn’t do anything, it means that GPIO pin is not being used. Go back set the currently used GPIO to none, then set the next GPIO with PMW1.

You will do this will ALL the GPIOs until you find the 4 you need. In my case GPIO4 was RED, GPIO5 White, GPIO 12 Green and GPIO 14 blue.

So once you know which pins are used for what, you want to set up the GPIO for Red as PMW1, for Green as PMW2, for Blue PMW3 and for White PMW4

I am no expert, but someone mentioned changing setoption37 to 63 I think. Again not sure, but my guess is that the default is PMW1 for Red, PMW2 for Green, etc, but if you change setoption you can remap the PMWs. The bulb I have is a RGBW hence PMW 1 red, 2 green, 3 blue, 4 white. If you setoption37 you change the order to something different, for example if you setoption37 to 6, it becomes R,B,G,Wc,Ww so red is PWM1, Blue is PMW2, Green is PMW3, and White is PMW4.

Hope this helps someone