Wrong Temperature Value on Multisensor

Tags: #<Tag:0x00007f325cee9d38> #<Tag:0x00007f325cee9b30>

Hi, i’m a newby in HA and I don’t know what I have to do to solve this.
I installed Hassbian on my raspberry pi3, i’m using the z-wave USB stick gen5 by aeotec to get values from my two identical multisensor gen5 by aeotec. I paired both successfully with the stick, they give me values about brightness, umidity and temperature. while the first two give me proper values, the temperature observed by BOTH sensor is -17,5 °C (in an envirorment with a temp of 19-20 °C). If I try to warm them just with my hands or clothes they reach values about 6500-10000 °C. Is there a way to fix this value? I heavly dubt that BOTH my sensor are broken in the identical way, but this not-linear temperature trend scares me.
thanks for considering this.
warn me if I missed the right category for the topic.

I have the same problem with 2 first gen multi sensors. After hours of playing around flashing firmware back and forth I managed to get them to read “somewhat normal” values but they aren’t working properly. They pretty much hover between 24 and 30°C between day and night despite it being much cooler inside my house. I didn’t get much usable help from Aeotec support, just the advice to try firmware versions. I do still find that occasionally after a Hass reboot the sensors (not necessarily both) will read either -17 or 6300 but then stabilise back to the still incorrect 24.

I hope someone can help us both!

I’ve got one of them, and it reports a temperature that’s about right - I haven’t checked it against another device, but if it’s wrong then it’s wrong only by a degree or so.

If the sensor is wrong by the same amount then you can change the configuration to apply an offset. In the first case though, it does sound suspiciously like broken sensors.

Is there a tutorial to do it?

I hope too!

There’s not one, because writing a tutorial for changing every setting on every possible device would be a major undertaking.

The process, other than calculating the offset, is relatively simple though:

  1. Open the Z-Wave control panel and select the sensor under Z-Wave Node Management
  2. Scroll down to Node Config Options
  3. Select 201: Temperature Calibration
  4. Apply the offset as explained here (sadly, Aeotec made this non-trivial)

It can also be done in HA using a sensor template.

thank you for your help, but I can’t find that option in my ozc(I selected the multisensor node)



so I don’t know where to apply the offset.
Furthermore

is for multisensor gen6, I don’t know if it’s the same for the gen5.

tomorrow I will consider sensor template.

Looks like you may be missing a firmware update for it, Aeotec’s site details how to do that.

that’s what I’m doing to offset the temperature -1,4 degrees of my non-zwave sensors

  - platform: template
    sensors:

      tmp_living_calibrated:
        value_template: '{{ (float(states.sensor.tmp_living.state) - 1.4 ) }}'
        friendly_name: 'Living tmp'
        icon_template: mdi:thermometer
        unit_of_measurement: "°C"
1 Like

sadly the first gen multi sensors don’t have parameter 201 so I guess I’ll have to try my first template

i’ve update it to v1.8 but I still don’t see the parameter 201. Always the same parameters.

now i’m going to figure out how to do it too, but if you succeed please pm me.

I am going to try what elRadix has posted just above. I’ll post my results once I get it done in the next day or so

This one worked for me:

I have to add 2°C to the value of the Aeotec sensor. Aeotec is crap!

I would have to disagree at least for the newer models. Did you do a calibration on it?

Did you check at 0°, 10°, 20°, 30°, 40° or only at 20°? At 20° they all show 20° because that is how they are adjusted.