Aeotec DSB05 Sensor temperature reading error

Tags: #<Tag:0x00007f3259d51c08>

Hi,

I have a couple of Z-Wave Aeotec DSB05 motion sensors. They also read temperature, luminance and humidity. The temperature scale is Celsius, but the reading for both of them is:

857484.4 degrees.

I’m pretty sure I’m not in hell at the moment, so assume that there is something wrong with the software which is producing the same reading for bother sensors of the same company…

(I also have Fibaro sensors and an Aeotec Multisensor 6, and they indicate temperatures in the habitable range…)

Would anybody have any idea on what the problem might be?

1 Like

@karlg I have the same Z-Wave Aeotec DSB05 motion sensor that is also reporting a very high temperature (6691C) reading. Did you ever find a solution to this problem?

Sorry Paul - no.

I have two of these sensors that are both reading approximately -17 degrees C, it would be great to work out a solution to this.

So I have actually worked this out now, go into the zWave configuration for the device and set config parameter 101 (group 1 reports) to value 225.

3 Likes

That’s brilliant!
Thanks for looking into it - and for posting!

Hi! Did you find a solution for this? I’ve set the 101 param to 225 but it still reports a -17 temp value (celcius)

No. I’ve stuck with the previous z-wave controller. Moving from one to another is a big commitment and the previous one has a lot of programming in it that just seems to work.

So, no resolution with the DSB05 issue. Sorry.

For me this actually worked. Setting 101 it to 225 sets all sensors to true. If you know how to read the manual, you’ll find out that:

  • Temperature - 32
  • Humidity - 64
  • Light Level - 128
  • Battery - 1
    Now just add the ones that you want to have reported, 225 is all of them.

Hi, do you sometimes get extreme values for sensors? Like in this pict? Thanks.

HATempExtreme

I just want to say that this also wroked for me. My DSB05 was reporting -17 degrees celcius.

Ive set the 101 param to 225 and had to wait 10 minutes for it to update