WT32-ETH01 seen by router, but offline in HA


I have bought a WT32-ETH01 board to be able to get temperature readings from a BME280 sensor through ethernet. I tried setting it up, it say there is no error. After that I remove the jumper from GPIO0 (next to tx rx pins) and ground and power it up again. It gets an IP from the router that I can see in my router, but in HA it stays offline and when i try to add it in devices it will say to make sure to add api line in the yaml file. I can ping the device from the router itself, but no other device can ping it on the network.

Anybody has an idea what am I doing wrong?

  name: wt32
  platform: ESP32
  board: esp-wrover-kit

  type: LAN8720
  mdc_pin: GPIO23
  mdio_pin: GPIO18
  clk_mode: GPIO0_IN
  phy_addr: 1
  power_pin: GPIO16
# Enable logging

  # Optional manual IP


# Enable Home Assistant API
#  encryption:
#    key: "pWh7LjnJFlCmWoL69jwUzvdJJDfUVJhWX/lT3AQx+6g="

#  password: "d862b4d7222154a0fda1036c1a4ec3a4"

  sda: 33
  scl: 32
  scan: true

  - platform: bme280
      name: "BME280 Temperature"
      name: "BME280 Pressure"
      name: "BME280 Humidity"
    address: 0x76
    update_interval: 60s

What IP address are you trying to ping from?

What exactly does it say when you do so?

Is port 6053 open on the device?

I was trying to ping it from and, they are on the same subnet as the wt32. I could ping it from which is the router. When it fails its just no response, 100% packet loss. I thought i dont have to open ports on the same subnet.

I managed to solve the issue.
Previously I used an arduino uno for ttl converter which worked fine, but it stopped working ( no serial answer) after a while. I found a d1 mini in my drawer and tried that and it seems like it did the job right and reports temperature as it should. Ordered a couple ttl converter to make my life easier in the future.