Wt32-eth01

HI all,
i try to set up a WT32-ETH01 for the first time. Both for me and for it. I am not an experienced user it is my 2nd board trying to set up and develop something.
I want to flash esphome
Up to now

  1. i wired it with a USB-TTL and connected to a laptop
  2. i started the esphome wizard
    add new device>continue>gave it a name>pick specific board>ESP32 Wireless-tag WT32-
    ETH01 Ethernet module> copied the encryption key>install
  3. found it on the web esphome >connect> it connected and i hit prepare for the first use
  4. then i edited yaml as follows:
 esphome:
  name: wt32-eth01-1st
esp32:
  board: wt32-eth01
  framework:
    type: arduino
ethernet:
  type: LAN8720
  mdc_pin: GPIO23
  mdio_pin: GPIO18
  clk_mode: GPIO0_IN
  phy_addr: 1
  power_pin: GPIO16
  #Optional manual IP
  manual_ip:
    static_ip: 192.168.2.31
    gateway: 192.168.2.1
    subnet: 255.255.255.0
#Enable logging
logger:
#Enable Home Assistant API
api:
  encryption:
    key: "rUZq9pgsOk8gMyHfZzNU2h...="
ota:
  password: "886073588f5b84e91"
#wifi:
  #ssid: !secret wifi_ssid
  #password: !secret wifi_password
  # Enable fallback hotspot (captive portal) in case wifi connection fails
  #ap:
    #ssid: "Wt32-Eth01-1St Fallback Hotspot"
    #password: "aMeilDo2y47I"
i2c:
  sda: 21
  scl: 22
  scan: true
sensor:
  - platform: dht
    temperature:
      name: "DHT11_Temp_on_WT32"
    humidity:
      name: "DHT11_humi_on_WT32"
    pin: GPIO36
    update_interval: 60s  
  1. i connected on wt32 a dht sensor on 3V3 GND and IO36
    6.reconnected to the laptop and via web esphome i installed the edited yaml
  2. disconected io0-gnd and txd rxd so it only be powered up via laptop usb (5v and gnd) and i connected on wt32 an ethernet cable
  3. it stays offline and logs are
    INFO Reading configuration /config/esphome/wt32-eth01-1st.yaml…
    INFO Starting log output from 192.168.2.31 using esphome API
    WARNING Can’t connect to ESPHome API for 192.168.2.31: Error connecting to (‘192.168.2.31’, 6053): [Errno 113] Connect call failed (‘192.168.2.31’, 6053)

what am i missing?

Adding it to ha?

yes i wish to add it to ha.

Well do so. Go to integrations. Click add. Choose esphome. Follow the dialog.

i have tried to flash it with every possible combination i could find. via esphome dashboard, web esphome, i have plugged and unplugged it many many many times. The only procedure seems to go to the end is the “prepare for the first use” but even then it doesnt connect even via wifi.
finally i tried to reset to factory settings where according to the manual “Hardware mode to restore factory settings: CFG pin grounding, restart the module”
I connected the 2 pins (CFG and a GND) with a jumper cable and i powered it up having connected only the 5V and the GND from the USBTTL. Its led turned on but how can i know if it has been reset?
COuld module be damaged after all these tests, trials, fails etc?

Sorry I thought you had flashed it but obviously if you disconnected the serial in step 6 you won’t have flashed it, because the first flash must be by serial.

i try to start over from 0

All you have to do is flash it over serial. Either from your laptop or from your ha machine.

i do flash it over serial but at the end it doesnt connect to LAN. i made a storyline with photos of all steps taken. Is it something wrong?.





How could you flash it over serial if you disconnected txd rxd.

I disconnected cables after flashing. Sometimes it is not clear that board has been flashed. There is no clear message that the procedure is over and successful. How much time does it need to be flashed? During flashing one more led is blinking on usbttl besides the one that is on. Should i use another flashing method? Is there any other utility to flash esphome? However the photos i uploaded are from my last try.

Not sure if it helps, but I just had similar issue. I discovered, that module keep resetting because brownout powered by flashing dongle.

Try better power source.

After having tried many different options and having tried to flash it (WT32-ETH01) enough times i finally made it work and connects to LAN. But it connects wirelessly. Then i edited yaml to set up ethernet connection and tried to install the new yaml. Yaml is tested no errors. It starts compiling it creates image but flashing fails with the message:
collect2: fatal error: ld terminated with signal 9 [killed]

I have a rpi 3b running HAOS, and there are connected to it 2 bluetooth mi thermos, 1 raspberry pico w (with 2 ds18b20 s and a dht22) and a some other integrations (22).
Could it be a matter of memory sufficiency?
If yes, is rpi that runs out of memory or WT32?
If rpi is running out of memory (normal memory usage @ 66%) this happens at the time that starts flashing the image in WT32? If i uninstall some integrations will it have enough memory? What is the min available ram to run smoothly?

i finally made it. i didnt flash the yaml. file through esphome directly but using modern format i created bin file and i flashed the .file using esphome web.
thank you all for the support

1 Like

Could you kindly send the bin file? No matter what I do, I dont get this thing up and running with ethernet…

I will post a good solution to get started with this board. Look for my new message about this WT32-ETH-1 board with Tasmota

I am using this config to get it started over LAN
be aware you have to put IO2 to ground at boot for ota to work.
(they added a GND pin next to IO2)

esp32:
  board: esp-wrover-kit
  framework:
    type: arduino

ethernet:
  type: LAN8720
  mdc_pin: GPIO23
  mdio_pin: GPIO18
  clk_mode: GPIO0_IN
  phy_addr: 1
  power_pin: GPIO16

ota works with multicast, so make sure you are on the same subnet as HA is
192.168.Y.X where the Y should be the same and X different (the subnetmask would be 255.255.255.0 in this case) otherwise HA cant find the esp-device and shows it as offline
(you can overcome this with some tricks)