WTH Does the TP-Link Integration still have the "unavailable" bug

Since I don’t see it mentioned in this topic, I wanted to add that I have worked around this flakey “TP-Link Kasa Smart” integration by enabling the TP-Link integration within SmartThings. The SmartThings Home Assistant integration then makes these switches available in Home Assistant.

Even if you weren’t using SmartThings before, installing the app, adding TP-Link then installing the SmartTings Home Assistant integration should make these switches show reliably within Home Assistant.

1 Like

Does that use local Kasa device API or cloud? If cloud, well …

I assume it uses TP-Link Cloud. Merely a stopgap until there is local API support I suppose.

For me although local is preferable my main problem was unavailable switches in the TP-Link integration. Loading them via SmartThings seems to solve that.

1 Like

The issue is that I think we’re all on borrowed time on TP-Link Kasa with respect to ability to maintain future local control. TP-Link is showing all the signs of working on preventing local control and so I think we’re in a race now. At least I am: need to convert all Kasa to 100% local (with existing automation and Alexa functionality) and block all firmware and other cloud communications for all Kasa devices … before they push a crippling update.


I just came here to say that I too was having a similar issue.
my TP Link switches have actually been rock solid. I’ve had them since 2018 and this is the first time I’ve experienced this problem.

  • Restarting HA did not fix my issue.
  • Reloading the integration did not fix my issue.
  • Deleting and reinstalling did not fix it either.

I have 14 of these switches and dimmers and I thought that they were all showing as unavailable, however, I noticed that 3 of them were in fact online. Those devices are installed upstairs and are on a different AP. So for fun, I restarted the AP on the main floor and voila, the other 11 switches are back online.
Here’s the odd part… not 1 minute later, the original 3 connected upstairs are now showing as unavaialble. I restart HA, reload the integration… nothing.
I reboot the AP upstairs… and now we’re back in business.
Super weird.

how do your 2 access points work together? if there is handover to each other and no/forced disassociation happening, the devices might lose the connection without knowing it.
I had to force my tp switches to a specific ssid on one access point to keep more stability. The multi AP one SSID wasnt really helping with these things

To add my experience with these plugs. I have a BT Smart Hub 2 with a number of the black discs. Until 46 days ago I was having all sorts of problems with not only the TP-Link devices dropping out, but other devices abandoning their nearby disc in favour of the much weaker main hub (specifically some bird box cameras).

Then, 46 days ago, BT updated the firmware on the Smart Hub 2, since when not a single problem with any device. They all stay connected to their nearest/strongest AP, whilst my phone switches seamlessly between APs as a wander around the house.

So it’s worth checking, especially if you have multiple APs, that your firmware is fully up-to-date and the forums for your device are not reporting strange glitches with connectivity. I know that the BT/Sonos forum are reporting similar drop-out problems.

Both my APs are connected via ethernet to my router.
I have 3 SSIDs, each floor has it’s own 2.4GHz SSID and my 5GHZ roams around.

This forces all my IoT devices to a specific AP.

Same problem. I bought a 4 pack of EP10 smart plugs. Initially, they all worked. Then they all went offline at the same time for about 12 hours, and only 2 of them reconnected to my router. All 4 have TX, only 2 have RX. What a joke. I bought these to replace X10 modules. Turns out tech from the '70s is more reliable.

Edit: They all work now and I’m happy again. I manually assigned IP addresses instead of letting DHCP do it and I also bound them to the closest access point and all seems to be good.

All my smart home plugs are Kasa and I have a bulb in my bedroom as my kasa. 90% of the time they are great and the power strips in particular are very useful but maybe once a month they have a fit and I need to reset everything to get them on HA again. This morning I noticed they were all gone again but nothing I usually do has worked to restore them this time. I even factory rest one my power strips and then tried deleting the integration and starting from scratch but the HA integration won’t even register any of my TP link devices anymore. I set static IP’s for all of them and then manually added them to the config but with no success. Looks like it might be time to migrate my set up to a new provider as the TP link integration has just been too unreliable over the past couple of months. Lesson learnt. Best to diversify as much as possible when it comes to device providers and wireless protocols

Update: After adding all the static IP’s to the manual config and wait about an hour the devices just suddenly started showing one by one. It happened after I went to look at the settings on the device through Alexa, I’m not sure if that’s related. Maybe that ‘kickstarted’ it back into action or something. Regardless I think I’m gonna be keeping my eyes peeled for alternatives

I was having same unavailable issues randomly on 20+ plugs(turns on/off pinball machines). I also happen to use hubitat C7 hub only for zwave and have the hubitat hub connected to HA via MQTT so i added the tp-link/Kasa outlets to hubitat instead of HA and seems to have fixed my issues. Not a great fix but it does seem to work now.

So maybe we need to collect data on model and hardware version, mine do also randomly go in/out. I previously had a bunch of HS200 V1 and HS105 V1 and they worked perfectly with HA and the app.

Its been a year or so and I had to swap out the HS200, at the time I got HS200 V3. The SD card also died at this time and I never got around to reinstalling HA until recently.

I had inconstancies with the app as well thinking it was my TPlink EAP APs, but have tested each AP individually and with roaming. Making sure no other devices are causing issues with the kasa devices.

The conclusion I have come up with is that V3 hardware as reported in the app have issues, this is the case with HS200 and HS105. I also have HS103 V5 and HS105 V1 and they are rock stable in the app and HA.

Reliability in the app seems allot worse now as well after the most recent firmware update for both HS200V3 1.1.5 and HS105V3 1.1.4.

Was this the fix? Add retries for tplink discovery (#52015) · home-assistant/core@8d8af60 (github.com)

My smart lights (KL125’s) are still disconnecting from Home Assistant, but not the Kasa app

oh man. one of those newbies who dropped a bunch of cash on kp115s thinking they’d integrate awesomely into HA and now they keep going “unavailable”.


If you setup dhcp reservations for each light, home assistant discovers / remembers them just fine

DHCP reservations help a lot, but absolutely does not solve the underlying integration reliability problem completely and is not “fine” — even with DHCP reservation some devices go unavailable intermittently.


Sorry if I came across as snarky, I was meaning that this quick fix works for me, but absolutely the problem is still a problem and ideally would be fixed.

The next homeassistant release should fix the connectivity issues (see https://github.com/home-assistant/core/pull/56701). The beta will be out soon, so it would be great if anyone having troubles could give it a go and report encountered issues so that those can be fixed for the next release. Now, if everything is working fine and/or you are feel that things have been improved, it would also be nice to hear :slight_smile:

To comfort anyone looking into getting tplink devices, I haven’t heard about the new encrypted local protocol being used outside of the UK (and only with HS1**, but who knows). The new protocol has been reverse engineered and there’s a partial implementation available, so adding support for devices using this protocol requires just some more voluntary effort to make it happen.

Also, as long as devices keep shipping with firmwares that are not blocking the local protocol, it is possible to avoid any cloud connectivity & updates by using the command-line tool shipped with python-kasa instead of the app.


I have 6 kasa plugs (one is the power strip). For some reason the power strip and the one with the power details (usage, etc.) are almost always unavailable and don’t come back when I reload the integration. IP address reservations already assigned but doesn’t seem to help. They’re in the same room as some of the other kasa switches and no more than 10 feet from a wifi mesh node. The power strip is probably 1 foot from the mesh node. Makes no sense. Everything readily available in the kasa app, just not in HA.

Any suggestions?