Now that you can merge lists of triggers (typically gotten from a blueprint), would it not be logical if the same syntax also worked for actions and conditions?
I.e. in addition to
triggers:
- triggers: !input my_triggers
we should also be able to use
actions:
- actions: !input my_actions
conditions:
- conditions: !input my_conditions
Yes, I know you can use sequence:
and parallel:
for actions, and for conditions use and:
or or:
. But for the sake of consistency and easier to read code, actions:
and conditions:
make more sense to me.
And speaking of consistency, with the (much welcome) recent syntax changes, anywhere sequence:
is used actions:
should work as a synonym, IMHO. This includes as part of a choose:
, repeat:
, etc.