WTH: i disable tab visibility to a user but it still is visible

So i wanted to give home assistant access to my child but only her room. So i made a user for her and disabled all other tabs for her but every time i start the home assistant app my overview page appears and she can control almost everything. If i click on her room then it dissapears until i close the app. When i start it again the overview page is there again. I use the android companion. What can i do about it?

Vote for your own wth!

How did you do this?

Custom Header?

If so, create a separate dashboard with the only view you want. Assign it to your daughter’s profile on the device.

Configure UI - Edit view - Visibility and there you can select which users see the view in the navigation.

I read the release notes religiously yet things like this still slip by me. :roll_eyes:

My suggestion of using a second dashboard would still work if you want something to use until this is fixed.

I have never tried making a second dashboard but i will look into it. The visibility option works just fine for my wife. For her i have disabled some configuration tabs that she does not need. I think that the problem is with the first tab. If i change the firts tab then the first tab will apear at the app start.

Yea this is why I ended up making a separate dashboard for each client.
On first load it would always show the full default dashboard and like you said my daughter could run a muck throughout the entire house.

At the moment it always loads your first / default view, regardless of visibility settings. There is a PR in the works to fix that here: https://github.com/home-assistant/frontend/pull/6567

Having a different dashboard for your child is the workaround until that gets merged. You can do that under Configuration -> Lovelace Dashboards. Since you already have a Lovelace view for your daughters room, you can enter “Raw configuration editor” and copy/paste the contents of that view into your new dashboard rather than recreating it.


I created a new dashboard and copied her stuff over. But how do i assign her to see it? Visibility settings?

On your daughters device, you would go to her profile page (the very last option in the bottom of sidebar) and then change the default dashboard there.

This is a device-specific setting, so if she has a phone and tablet for example, you’d have to do it on both.


Thank you very much for your help! Everything is working like a charm now.

The PR https://github.com/home-assistant/frontend/pull/6567 has been merged mid of September so this can be marked as solved I think.

This is still an issue in version 2021.4.4.
On first load, users can see all tabs (and access & control all dashboards).
If you click outside of the dashboards and back, only the permissible tabs are visible.
I’d greatly appreciate if anyone has any advise to solve properly?

Gwumm, I can confirm this is still an issue for me today. My users on mobile devices will always see all dashboards at first, then if they pick one, they will see only the one they are authorized for.

I read elsewhere that this behavior happens “only once” but I can confirm this is not the case. Users will see all dashboards again and again at random intervals (maybe when the app closes on the phone, or the phone reboots, I haven’t been able to determine the cycle).

Hopefully this gets noticed soon!

For my installation, I have security camera feeds that not everyone is supposed to be able to see – but they do, because of this bug. For me, this is a big bug. For others, maybe not so much, so I am just waiting patiently till someone figures it out. :slight_smile:

sorry to bump this, but I can not get the visible: option to work on my views, and this seems to be the only related topic around.

Have some dashboards using the require_admin: true which works fine.

However, If I use the visible option on a regular dashboards tab/view:

title: Settings motion
path: settings_motion
visible: 3a8redactedb63


title: Settings motion
path: settings_motion
  - user: 3a8redactedb63

which is the hex code in my own user settings (and I am admin) the view is still visible for all other configured users.

is this a bug, or user error?
issue: https://github.com/home-assistant/frontend/issues/10366