WTH the UI for binding devices in ZHA is so poor?

I just wanna bind a light with a motion sensor, both from the same manufacturer.

I can bind using the manufacturer’s apps, but not at all in Home Assistant and I’m not sure if this is a defect on HA or if am I missing some step as the interface is so poor.
I’ve tried to bind a Philips Hue motion sensor with a Philips Hue light, also tried to bind an IKEA remote control to an IKEA cover, always the same.

1st: It’s hard to find it.
WTH you have to look for “Manage clusters” and not “Manage bindings”. Probably much more users try to manage binding than managing clusters.
Why don’t split the two things into two different dialogs. It’s so confusing as it is.

2nd: You have to start from the right device
I cannot bind the light to the motion sensor, but I can bind the motion sensor to the light.
WTH isn’t the system smart enough to do the double sided check and give me the options?

3rd: No feedback when you click “Bind”
WTH the system doesn’t shows any visual feedback when I click “Bind”? Could be a dialog saying it succeeded or failed, could be the button changing colour (like in other areas)… but some feedback, please.

4th: Button “Unbind” enabled even when no bind is set
WTH isn’t this button greyed out until I have some bind? This is how it works in other areas, like “Save” is greyed out in the card editor until you change something in the card.

I’m probably going to ask a stupid question but:

Why wouldn’t you want to use automations to link these things together?

Because it allows them to work without any external intervention even if HA is down. Just like ZWave direct association. It’s quite useful.

That said this is all stuff in the add in and isn’t the purview of HA core.


I do use automations now days, but binding directly could be useful for situations when you need that expected behaviour/automation even when Home Assistant is out (restarting, etc).

I have to say that not being able to figure out how to do this when I got my first Zigbee devices and didn’t know what clusters even were (I was coming from Zwave), made me drop ZHA and switch to deConz where I can do it easily in the Phoscon app.

Yeah, I’ve used deConz before and this was pretty easy. Unfortunately this is not the same for ZHA.