WTH we see only device trackers on the map and not persons?

I would like to show persons on the map panel, because the goal of the person entity is to group several tracking devices and assign them to a person to locate the person itself. Why would i need to see the devices ? I need to see the persons !
Best would have the choice to see what i want on this map panel.

Are you talking about the Map Lovelace card? On mine, I have persons available along with device trackers.

Nope i’m speaking about the map panel that you have in the sidebar.
And btw it looks even more WTH that the card allows something that the panel don’t.

That’s odd, because on my Map panel, I only have zones. No devices and no people at all.

Yeah, it’s a bit wonky for sure.

On mine I see only the both android phones where the Home Assistant companion app is installed and setup with mobile_app integration.
All devices that are home are not shown :wink:

Ahhhh, OK. Shows how often I use the actual map panel. :wink: My wife and I are both at home, so that explains why I’m not seeing anything except for zones.

1 Like

A workaround you can use for now:

  1. In Configuration -> Lovelace Dashboards, create a new dashboard called “Map”
  2. Take control of that newly created dashboard (3 dots in top right corner -> Edit Dashboard -> “Start with an empty dashboard” toggle)
  3. At the top of the screen in your header area, you’ll see an orange plus button. Click that to open the “View Configuration” dialog, and change it to “Panel Mode” then hit save.
  4. Now click the circular orange plus button to add a Lovelace card for “Map”
  5. Customize the sidebar (long press on sidebar header, or go to profile page -> edit sidebar) and remove the original/default Map sidebar item if you wish.

Now you will have complete control over every device tracker and person that shows on the map. You could add only the ones you want to see.

This method doesn’t hide devices that are at home either. And with this method you could get light (white) map tiles while still using dark mode.


This is a solution but not covering all cases.

My person.sebastien is defined with 2 device_tracker :

  • mobile_app
  • Router device tracker (Freebox)

When i’m back home, the person is set home by the router integration and then the icon doesn’t display anymore on the map…even on map card. Not only on map panel.

So i can still use a workaround of the workaround : display the mobile_app device tracker instead of the person. But it will not be synced with real state as the mobile_app takes longer than router device tracker to set me home.

1 Like

I’m following up with the same request.
Persons should display on the map, not tracked devices.

I over came this by manually setting the longitude, latitude, altitude and accuracy for the device_trackers that are from the router… This will then trick the person component to having those coordinates when the tracking is on the router… Just goto configuration then customisation and edit those device tracking entities with the coordinates of your home

I’m trying to do the same but I can’t, can you show your config?


make sure it matches the other device trackers attribute keys (case sensitive) (they all should be lower case.

I cannot see any person or device. I have set up correctly both my person entity and device_tracker.
I configure the map to show both person and device_tracker but none is showing on map.

My mobile app is giving the correct info since I can read the value of my tracker and it is showing zipcode, city, latitude, etc… Correctly