WTH: Why can't I change the input sensor of a threshold sensor (helper) when it was created via user interface?

in opposition to the yaml configuration it’s not possible right now to change the input sensor (for example: to find out if it’s dark in a room you initially used the value of a presence sensor but now want to switch to a more suitable sensor).
in addition it would be great if it would be possible to use templates for the upper and lower threshold.

Did you keep checking on this? i tried to even find yaml file, but i was not able to find (I check files under .storage, where other helpers definitions are)


Has this been addressed in a recent update or is it still not do-able ?

It’s still not possible to change the input sensor. +1 from me.

I have one saying the input is unknown and I can 't figure out what the input sensor was? I guess I will have to recreate the sensor.
+1 from me.

Go to developer tools → states page and look at the entity_id attribute for the threshold sensor. That will tell you the source entity.

Developer tools are a workaround but it’s a big pain not to be able to see/change the source entity for a threshold sensor. There’s no explanation in the docs, there’s no explanation in the UI itself. It’s just not understandable for normal users.

No they aren’t. Developer tools were built before all the fancy UI stuff you see today. They are the original way to find information about entities, and you should always refer to that table. Developer tools has been in the system when I started using HA in 2015. Sorry this doesn’t work for you.

@petro, I’ve started using HA 2023 and the developer tools are labelled as “developer”, which I wasn’t at all as a novice user. I even think they weren’t even available until I enabled “advanced mode” after a while. So while I found the solution, I’m posting here to prevent many other new users from having the same issue.

I do think that anything that can be created in the UI should be editable in the same UI. So when a threshold sensor can be created in the UI, there should be an intuitive way to change the input sensor in this interface too. And as long that feature isn’t implemented, it should be explained in the docs how to change the input sensor.


This seems like such a small change to make I am surprised it hasn’t been addressed yet. I really hope it gets addressed soon.
I hate having to delete the helper, and then create it again just so I can update the entity it relates to, and then find all the places I used it and update those.

1 Like

+1 also for me

+1 as well for me. This is beyond frustrating.

It’s now fixed. Will be part of 2024.07.


YEAH! Thank you so much, this is a really nice improvement, it’s something that i actually will use a lot in the future.
Thanks again!