WTH: Why is HA still showing AM/PM instead of 24H?


Also the logbook:


OS region settings:


This has been discussed many times before and still the issue persists. Please just add a config in the user settings so we can manually change it in case the detection is incorrect (for me it has never been correct since I’ve started using HA).


And a configurable first day of the week, in pretty much all of Europe we use Monday as the first day, not silly Sunday and still I get the following date picker with Sunday as the first day in the Logbook tab:

You have my vote. It is a long standing issue, and has nothing to do with OS or browser regional settings.

If not reported yet, with AM/PM the order of hours in date-picker is confussing.

For example to select time range from midnight to 3am you have to set 12pm to 3 am. The 12pm is pretty awkward to me. in addition it’s on the end of the list while intuitively I would look for midnight at list beginning.

I admit I’m not used to 12-hour system and this is probably the case. But half of the planed uses 24h system. I would appreciate option to change time format

1 Like

In fact, from what I see, it’s not consistent. The 24-hour system is already used for the logbook (so I guess it’s based on browser’s or OS’s regional settings) but the 12-hour system is still present in the chart / graphic cards.

1 Like

Strange, just checked this and my PC is set to 12 hour but the logbook page, history page and the graphs all show 24hr

It is not consistent at all



1 Like

Yes please! Make everything 24H.

1 Like

I’m in the US and used to 12 hour, but I hate it I would love a user option to set the preferred date and time format. Could be because I’m a sysadmin but I far, far prefer a proper ISO date (YYYY-MM-DD) and time (hh:mm:ss) for everything. It’s so, so much easier to correlate things!


What language have you set in your Home Assistant profile?

We added a new language a while ago, English GB, that will render times in 24h format instead of the other English (American) that will use the 12h format.

I know we are not consistent at all places, but I know the logbook should be correct.

Could you confirm this?



It makes HA look very unprofessional with a mix of different datetime types.

That’ll be why all mine show in 24hr, even though my pc is set to 12hr. I’m using English GB

Mine is set to English GB, but see the screenshots higher in the topic.

I couldn’t agree more. This issue has been plaguing the forums for years. It’s time to put it to bed

Yes, so the logbook is correct like I stated, and the history graph needs be adjusted.

If someone can make a list of the places that are wrong, I can check if we can fix these.

For me the following are all AM/PM instead of 24H:

All history graphs
All history graph popups (more info on sensor cards)

Then your language setting probably is set to English instead of English (GB)?

Yep, correct.

Changing to English GB fixes some places (logbook and history tab), but I still see it at the sensor popup graphs:

That’s strange. I also have mine set to English (GB) and the more-info graphs show correctly as 24 hour for me:

Edit: In fact, even when I have it as “English” I still get it 24 hour in the popups (but 12 hour elsewhere) so I don’t know where that’s coming from.