Wyoming protocol

trying to install the assist microphone add on; in the process, i am asked to add the wyoming protocol, which needs a host and a port; any input on what to type in there?

1 Like

I’m having the same issue. I installed assist microphone, here’s some instructions (from the page):

How to use

Before running the add-on, you must configure it with a long-lived access token from Home Assistant. To create a token:

  1. Go to your profile page in Home Assistant
  2. Scroll down to Long-lived access tokens
  3. Click Create token
  4. Provide a name for the token and click OK
  5. Copy the token using the copy button
  6. Paste the token into this add-on’s configuration page
  7. Click Save and then start the add-on

After this add-on is running, it will be automatically discovered by the Wyoming integration in Home Assistant. To finish the setup, click the following my button:

When I click on “Add Integration” i see the following dialog and nothing I’ve tried works.

Any ideas?

So you’ve successfully setup the add-on and have it running, correct?

Yes, Assist Microphone is installed as an Add-On and is running.

i also managed to get the add-on running, but no clue which host and port to type in for the wyoming protocol

I am running home assistant supervised on debian.

Goto settings → Add-ons:

  1. Install piper form the Add-on section
  2. Run piper in the Add-on section
  3. Install whisper from the Add-on section
  4. Run whisper form the Add-on section

Goto settings → Devices & Serivces → Integrations

  1. Add the wyoming integration
  2. piper and whisper are detected automatically → no “host & port” popup appears

I had the same problem, disinstalling, reinstalling and setup It immediately when It popup in integrations worked for me.

thanks, that also worked for me for piper and whisper; but still, for assistant microphone, the host and port pop-up appears

thanks, and just to be clear: what did you uninstall, reinstall and set-up again to make it work?

I was referring to Piper and Whisper. When I installed those, they show up in the devices page but I didn’t immediately hit “Configure” and when I back to devices page later they were no longer shown there to configure. I tried “Add device” for Piper and Whisper but both require me to provide the host and I had no way to proceed.
Uninstalling both, reinsalling they show up again in the devices page and immediately clicking “Configure” works, host and port were no longer asked.

For Assist Microphone I don’t remember I had any issue with the installation.

tried everything i could think of (including deleting everything wyoming related, rebooting etc), but still: wyoming does not discover assist microphone despite the assist microphone add-on apparently running; any ideas?

Hi, I’m having I think the same issue as mentionned here. I’m trying to setup whisper / pepper which requires Wyoming protocol.
But Wyoming protocol asks me to enter a host and a port?
image

Do you know what are the value to add ? When I read the doc it lets think there is nothing specific to do.

I’ve nothing already installed so I can’t test the previous solution.
Thank you

in case it could help other people having the issue I had. when you are running HA OS do not try to install integrations before adds-on as I did :slight_smile:

  1. install adds-on piper and whisper
  2. start piper and whisper (as mentionned)
  3. add wyoming integration

my issue was to try to install “pepper/whisper” by adding its integration :man_facepalming:

For anyone else that was still not able to figure out what the Wyoming dialog is asking for, here’s what worked for me:

  1. Add the piper, whisper, and openwakeword addons

  2. Start them all up as you add them. In each addon, you will see a hostname to the right of the Start on Boot slider. These hostnames should be “core-whisper”, “core-piper” and “core-openwakeword” respectively. If you go into their configurations, and show Disable Ports, you will see a port listed. Don’t change anything here, but the ports will 10200 for piper, 10300 for whisper, and 10400 for openwakeword.

  3. Go to Integrations and add Wyoming protocol

  4. For the first time dialog, use Host=core-piper and port 10200 (or whatever hostname/port you noted above in 2)

  5. Now you will have a Wyoming section in Integrations. Go into it and Add Entry for the remaining two, core-whisper/10300 and core-openwakeword/10400

Now you have all three entities available for fixing the STT, TTS and Wakeword options in the Voice Assistant - Home Assistant pipeline, or make a new one.

The documentation and the responses in these forum posts is less than useful. I’m not sure if in older installations this stuff is just not picked up automatically and has to be manually added as above, or if there is something wrong in our installations, but this was a pain to figure out and nothing here, in github or in documentation is helpful for fixing it.

Hopefully this helps out some other poor idiot like me going forward.

1 Like