Wyoming-Satellite , openwakeword fails at startup

Running on Raspberry pi 4 (8gb):
Debian GNU/Linux 11 (bullseye)
64 bit

I am trying to setup wyoming satellite but get this failure on both the raspberry pi bullseye 32 bit (Pi0 2W) and 64 bit (Pi4).

I have tried the following:

  • uninstall existing numpy and install opencv-python
  • uninstall numpy and reinstall numpy

wyoming-satelite has no errors…
Not sure what else to do. Here is the error I get from wyoming-openwakeword:

wyoming-openwakeword.service - Wyoming openWakeWord
     Loaded: loaded (/etc/systemd/system/wyoming-openwakeword.service; disabled; vendor preset: enabled)
     Active: active (running) since Tue 2024-06-18 12:08:30 CDT; 6min ago
   Main PID: 519 (python3)
      Tasks: 5 (limit: 8755)
        CPU: 12.243s
     CGroup: /system.slice/wyoming-openwakeword.service
             |-519 python3 /home/pi/wyoming-openwakeword/script/run --uri tcp://
             `-664 /home/pi/wyoming-openwakeword/.venv/bin/python3 -m wyoming_openwakeword --uri tcp://

Jun 18 12:15:22 pi4 run[664]: AttributeError: _ARRAY_API not found
Jun 18 12:15:22 pi4 run[664]: ERROR:root:Unexpected error in wake word thread (alexa_v0.1)
Jun 18 12:15:22 pi4 run[664]: ImportError: numpy.core.multiarray failed to import
Jun 18 12:15:22 pi4 run[664]: The above exception was the direct cause of the following exception:
Jun 18 12:15:22 pi4 run[664]: Traceback (most recent call last):
Jun 18 12:15:22 pi4 run[664]:   File "/home/pi/wyoming-openwakeword/wyoming_openwakeword/openwakeword.py", line 248, in ww_proc
Jun 18 12:15:22 pi4 run[664]:     ww_model = tflite.Interpreter(model_path=str(ww_model_path), num_threads=1)
Jun 18 12:15:22 pi4 run[664]:   File "/home/pi/wyoming-openwakeword/.venv/lib/python3.9/site-packages/tflite_runtime/interpreter.py", line 464, in __init__
Jun 18 12:15:22 pi4 run[664]:     self._interpreter = _interpreter_wrapper.CreateWrapperFromFile(
Jun 18 12:15:22 pi4 run[664]: SystemError: <built-in method CreateWrapperFromFile of PyCapsule object at 0x7f9af423c0> returned a result with an error set

To be honest, i think you’d be better of posting in it’s Github-repos

I’m getting the same error. Did you managed to solve it?

I had problems installing the openwakeword with the tflite-runtime-nightly but fixed this by removing the -nightly from the requirements.txt file. now the install works but
I’m also getting the same error as you.

I reposted on github for wyoming-openwakeword. Thanks!

[wyoming-openwakeword fails at startup · Issue #24 · rhasspy/wyoming-openwakeword · GitHub]

1 Like

I did the same…

Not so far. Thanks!

Hope the Author catch it up, he might have had same experience during his dedicated work

Yeah, Im having the same issues. I built 4 of these a few months ago. Trying to build a 5th now and it fails after Open wake Word is installed.