Wyze Bulb WLPA19 - Tasmota Integration

I went through the process of opening up a few Wyze WLPA19 (white) bulbs, carving out the potting compound, wiring up and flashing them with Tasmota (12.0.2). Very easy process. Home Assistant is running on Bodhi Linux, along with Mosquitto MQTT broker in Docker on the same box. Setting Option19 on and off. The device is detected by the Tasmota Integration or MQTT based on config. Focusing on Tasmota discovery… I can see the state change in Home Assistant when changed manually via the bulb’s HTTP interface, but cannot change the state from Home Assistant. When attempting state change, the bulb reverts back to its prior state in HA, and the bulb physically does nothing. Has anyone confirmed that the documented template is correct?

Template: {“NAME”:“Test Bulb”,“GPIO”:[5728,0,0,0,0,0,0,0,0,416,417,0,0,0],“FLAG”:0,“BASE”:48}

Console displays changed state when manually performed, but nothing when attempting via HA.

I feel I am 90% of the way there, and this is some simple overlooked option or config setting.

Thanks for taking the time to read through this!

It appears my Published commands are never getting processed through the broker. Not sure if this is a permissions problem or some other config oversight. I have MQTT Explorer connected as the Admin user.

Does anyone have any ideas where I should be looking?

I finally figured out the issue. I was using the MQTT Administrator credentials for the MQTT extension in Home Assistant. I changed the MQTT credentials to match the Tasmota device MQTT client connection and everything works perfectly. Administrator, by default only has topic-observe role (Read only access to the full application topic hierarchy) where as client role (Read/write access to the full application topic hierarchy) by default.

Figured I post this finding in the event anyone else makes the assumption that administrator has full access to the topic hierarchy.