Wyze Cam V3 RTSP Streaming Issue

I finally got around to updating one of my Wyze V3 cams to try it out with HA and the Wyze RTSP mod. Thanks to everyone’s examples in the forum here, I was able to get up to speed quickly.

I have excellent Wi-Fi here at my home with the Google Nest Wi-Fi mesh router and points. To that end, the camera (even if it’s in the same room as the router) suffers from this issue:

When looking at the video stream, it shows video not for long. It constantly shows me the spinner in the middle of the video, and watching the time stamp in the lower right corner it freezes a lot. At times the video window will close, then open back up on its own when it’s got a good stream. The “State” in the Developer Tools for the camera changes from “idle” to “unavailable” and back and forth quite often.

I’ve tried the following examples in my camera.yaml:

    - platform: ffmpeg
      name: Cam
      input: -rtsp_transport udp -i rtsp://secretuser:[email protected]/live


    - platform: ffmpeg
      name: Cam
      input: rtsp://secretuser:[email protected]/live


    - platform: generic
      name: Cam
      stream_source: rtsp://secretuser:[email protected]/live

I’ve tried regenerating the RTSP URL in the Wyze App. I’ve tried restarting the camera. It’s the same behavior no matter which configuration above I use.

If I monitor the feed from the Wyze app on another device (iOS or Android Wyze apps), it’s flawless… solid video, zero interruptions. So I don’t believe it’s a network issue.

Any suggestions on what to try here?

I tried playing around with MotionEye (within HA) and it seemed to work a little better than the native HA integration, so I’m still wondering why HA by itself is so unreliable. Is anyone else encountering this issue?

I’ve got the same issue. I’ve loaded a few Wyze V3 and a V2 into HA with the RTSP firmware on a microSD card.
Camera entity is loaded in both “generic camera” but I’ve also got the RTSP streams in Frigate (two of the V3)
I like to think my network is good, a combination of wired Deco M9 and a few wireless M5s with 100mbps download speed.
My cameras show idle to unavailable constantly in HA however, and this it he confusing thing when I load the stream in the Wyze app it streams without an issue. I had the app open on my phone and tried opening with Frigate or Generic camera and it would say unavailable. Clearly the device is connected to the internet and I cannot see big gaps in its recordings on the SD card so I can’t image its going off/turning off. So why is HA saying unavailable?

It does the same thing for my AirTouch AC controller. Unavailable and then On when I switch it on.