Wyzesense not working after upgrade

After some time I decided to upgrade Hassio (running on Ubuntu / Docker), and also the Wyzesense component (from version 0.6). I have a motion sensor and two door sensors, one of which no longer functions after being left outside to trigger when the gate on my fence opened (thought it would be an interesting test, but unfortunately a failure). On installing version 0.8 and restarting the devices showed as unavailable, which I expected since the upgrade suggests that users must ‘retrigger’ the devices to have them report properly. I went and triggered both good sensors, but no luck. Uninstalled Wyzesense, reinstalled it, restarted, triggered sensors, still not working. Tried reverting to version 0.7, then triggering, still no luck. Reverted back to 0.6, triggered, again, no luck. Uninstalled, restarted, reinstalled 0.8, restarted, triggered sensor, will not work.

Any ideas on how to get these sensors working in the latest version of Hassio?

I also don’t see anything in the Services section for Wyze devices, FYI.

Also, I see this in the logs:

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/entity_platform.py", line 178, in _async_setup_platform
    await asyncio.wait_for(asyncio.shield(task), SLOW_SETUP_MAX_WAIT)
  File "/usr/local/lib/python3.7/asyncio/tasks.py", line 442, in wait_for
    return fut.result()
  File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/config/custom_components/wyzesense/binary_sensor.py", line 78, in setup_platform
    _LOGGER.debug("Attempting to open connection to hub at " + config[CONF_DEVICE])
TypeError: can only concatenate str (not "NoneType") to str

Problem solved (I think). I had the integration set to automatically identify the bridge, which was working before I upgraded, but appears to no longer be functioning. I unplugged the controller, plugged it back in, ran dmesg and saw it was on hidraw2, so once I set that in configuration.yaml and rebooted, then retriggered the sensors, they showed up correctly.

I saw the same thing when upgrading to 0.112. I hard set to /dev/hidraw0 and rebooted. All is working now.

OK good. Does that setting tend to persist on reboot? Or should we be looking for a technical solution to fix the port auto-discovery?

It persists in my instance. I am running Docker on a NUC. I may try the auto again to make sure that is the issue.