X10 automation?

From Armbian config’s wiki page:

Screenshot from 2020-09-17 09-35-14

Key phrase there is “within Docker”.

also this time for reliability/performance, before installing HA, I’ll be using armbians built in script to move the OS over to the attached sata drive from the sdcard (my bananapi has a built in sata port)

None of that addresses the limitations I’ve mentioned. :man_shrugging:

I’ll be honest, I’ll only be using the HA for quick mobile control of all my chromecast devices around the home, and also my electricity provider gives agile pricing (https://octopus.energy/agile/) and someone has created a guide for setting up HA to automatically switch on/off devices when the hourly electric price goes below a certain figure (in my case a x10 unit atttached to my immerison heater)

few weeks ago, there were actually hour slots at night were the agile price went below zero and people were being paid for using electricty … mad corvid consequence world!

PS I already control my X10 devices using homegenie, have been using it for several years years reliably… I even voice control my old x10 devices using a combo of google mini’s and ifft google asistant recipies calling my homegenie via webhooks :slight_smile:

Looks like you don’t need my help anymore. Good luck.

thanks, its your guidance that gave me a “solution” :slight_smile:

Then I suggest you mark my post with the Solution tag to help other users find it. It will spare them the time and frustration of discovering Heyu is inaccessible when Home Assistant runs in a docker container.

It does indeed. Works perfectly in the Virtual Environment install

Just to confirm Heyu works fine in a Virtual Environment install (or whatever it’s called these days, Home Assistant Core I think) on the same machine once the Heyu service daemon is set up correctly.

Just search the forum here for previous posts on the subject.

I think you may have skipped a few of my posts because that’s already been established (and is not the installation method I was referring to when I stated that it doesn’t work).

What doesn’t work is when Home Assistant runs in a docker container, which happens to be three out of the four official installation methods … and the way harrys is running it. Heyu exists outside the container, in his armbian OS, where it’s not accessible to the X10 integration (running inside the container). If there’s a way to make it accessible, I don’t know how.

Yes I was just confirming with him that as a user of Heyu in a Home Assistant environment that it does in fact work for me.

I imagine if @harrys had realised that Home Assistant Core (previously called a virtual environment) was the quickest and easiest route to go to get Heyu working in HA with his simple X10 HomeGenie setup that’s the route he would have chosen. The fact that he chose a Docker install initially was more by accident than design.

I’m sure he will in due course mark the fact that Heyu is not an option in Docker but will indeed work with HA Core.

Your previous post was a direct reply to me (the post’s upper right hand corner shows that). :man_shrugging: Then you direct replied to harrys.

Harrys will have to decide if getting the X10 integration to work is worth losing all the management conveniences provided by the docker-based installation methods.

When I have a moment, I may submit a PR to amend the X10 integration’s documentation. It should advise users that it only works with the Home Assistant Core installation method.

@harrys, I just created an addon to allow control of X10 via CM11. This should allow you to convert to Home Assistant OS without losing X10 connectivity

It uses MQTT to control the X10 devices, using Heyu under the covers, so all you’d need to do is convert your old X10 entries over to MQTT entries. It also updates state in HA correctly when using X10 remotes. Note only ON and OFF are supported, no dimmers (the old HA X10 didn’t really support them either from what I found).

I wrote this for a friend of mine who also still has some old X10 devices in use and who wants to convert from the ‘venv’ style (hard for him to support with lack of Linux knowledge) to Home Assistant OS.

I’d also be willing to package ‘mochad’ into a addon if there is still interest.

Here’s the forum post with details:

Home Assistant Add-On: X10 (CM11) to MQTT Gateway - Home Assistant OS - Home Assistant Community (home-assistant.io)

This add-on has recently been updated to also support the CM17A “Firecracker” wireless controller. It works with the CM17A alone, or in tandem with the CM11A. In the first configuration, it does not update the ON/OFF state when X10 commands are issued by other remotes or wall switches.

Thank you Mark for your excellent contribution to the community.

I am reopening this thread, because I’m not seeing a solution that currently works with HAOS. I’m running HAOS on a Raspberry Pi. I have a CM11A attached to a USB serial adapter. The CM11A works fine on the Pi if I run an OS other than HAOS with heyu - say, Raspberry Pi OS.

The doc at Heyu X10 - Home Assistant states that “heyu x10” is required, but does not describe how to install heyu. heyu is not shipped with HAOS.

I started the terminal and download the heyu source with wget . I ran Configure, which created a Makefile.
However, there is no make for me to run. Or any compiler or linker installed, as far as I can tell.
apt or yum are not available to install these missing packages.

So, how is one supposed to get heyu onto HAOS to use this integration ?

The page I linked to above notes that it is only used by 2 installations at this time. Does it still work with the current HAOS ?

@madbrain , did you make any progress last month?

I was testing HAOS in a windows VM, using markm’s heyu to mqtt addon. It would catch incoming X10, but not send x10 from HA. I compiled Heyu and tested it on a debian machine to confirm I could send x10 via the command line - success. I never figured that out why HAOS coudn’t make correct use of heyu. Attempt #2, OS on bare metal. Well, my available hdw requires some non-free drivers, so I coudn’t get it to network. I wanted OS for the addon integration, but I’m now officially frustrated with it because it’s so difficult to see under the hood. I’m resisting Supervised on linux because there’s just so many ways for it to go wrong. So, attempt #3 is fresh Debian with HA in a container. It’s up and running, but now, how to add X10?

A container for Heyu (using kevineye’s docker) seems to fire up ok, but now I get the error almost exactly as harrys. I figured if they were both in containers, they would ‘work together’. My thinking is obviously too simple…

Sorry, I just saw your response. Yes, I made progress. My config works fine now.
I have both a CM11A and a CM17A connected inline via a serial dongle.
I’m not using heyu, however. I’m using Mosquitto and the X10 to mqtt gateway.
The CM11A is using for receiving messages. And the CM17A for sending them. This is because my powerline is very noisy.
See Home Assistant Add-On: X10 (CM11) to MQTT Gateway

This was a PITA to configure .

Here are parts of my config, which may help.

having great luck using the INSTEON integration. still works just fine. Using an Insteon 2245 hub.

To control X10 devices ?