Xiaomi Air Purifier 2 not available?

Putting in the config options with my token results in my air purifier being not available. Does anyone else have this issue? I bought it because of the integration :confused: I took it out of my config but I’ll put it back today so I can post the error logs.

Please enable debug logging for miio and homeassistant.components.fan.xiaomi_miio in your configuration.yaml and post the results here. Ping @syssi

1 Like

think you have the same issue as I had:

1 Like

Hmmm maybe i’ll try this. It’s weird because my vacuum works just fine and always has…

mine used to work fine until I upgraded to 0.59, after that no matter what I tried it would show up as unavailable. This solved my issue, and I know there are others with the air purifier who also experience the same issue. It only takes 30 sec to implement, if that doesn’t fix it, you may have another issue…

I’m on hass.io, think I could still find a way to manually edit the miio python file?

not sure of the structure of hass.io, maybe here?

Thanks appreciate the response! I’ll check it out when I get home.