Xiaomi Aqara motion sensor (RTCGQ11LM) not changing motion state

So, I’ve trying to get to work the motion sensor in mi Hassio and it seems something is not working properly because I cannot detect motion state change. I have tried the Xiaomi MiHome with an automation plan and it works.
Oddly enough it always says status “clear” in the log and in the status:

No motion since: 0,
battery_level: 89,
friendly_name: Motion Sensor_158d000272b9d1,
device_class: motion

There is something that strikes me as strange, the lux detector is working and detects illumination changes.
Maybe the motion component is not using the correct code, seems it should detect a sensor_motion.aq2 instead of motion

Also using Node-Red debugging capabilities no event change is broadcast when the motion should be detected.

Hassio version: HassOS 1.13
Home Assistant version: 0.82.1

Any clue?

I had similar issue. I removed it from HA and kept re-adding manually until it worked.

If you need to know how to remove it from Zigbee let me know. But that worked for me

So, I used https://github.com/svrooij/node-xiaomi2mqtt and it seems to detect the motion no_motion statuses. I don’t know how to manually add a binary sensor nor how to remove it form HA. (Removed it from .storage/core.entity_registry but nothing happened)

Having the same problem. The state of the motion detector does not change. Tried resetting several times to no avail.
Would love to know how to remove the entity from zigbee completely if possible.

Same problem here, any solution?


I am new to the home assistant and Xiaomi platform and I am having the same problem with the motion sensor. Are there any updates or fixes? stratplayer said that he has a workaroud, are there some instructions on how to do that? If not can someone recommend motion sensor that works (preferrably batteryless)?

Same here.

Solved. I posted the solution here: PyXiaomiGateway Problem: {"error":"Invalid key"}