Xiaomi BLE temperature stopped working after update to 0.98

I have a Pi3 B+, Hassio, and I have three Xiaomi BLE Temperature and Humidity sensors. All of them were working until now. Today I have updated from 0.95.4 to 0.98.5 and all of the three sensors stopped working.

Log shows:
Updating mitemp_bt sensor took longer than the scheduled update interval 0:00:30

My config is:

  # XIAOMI Bluetooth TEMP and HUMIDITY sensors
  - platform: mitemp_bt
    mac: '4C:65:A8:D6:6B:03'
    name: Bedroom
    force_update: false
    median: 1
      - temperature
      - humidity
      - battery

The entity shows state unknown.

Downgrading to HA 0.95.4 and it works again.

I’m running the same sensor (with the sensor.py of dolezsa) and it works well with 0.98.0 docker version…
Till this is analyzed, you might want to upgrade to that version.

Thanks. I am on 0.99.0 at the moment and still doesn’t work. I looked around the internet and on this forum and it seems to me I am not the only one having this problem.

I use hassio so I don’t have access to sensor.py, but I will give it a try to use it as a custom_component.

My suggestion was more to do a downgrade to 0.98.0, which works well in my case.
And I will take your hint to not do the upgrade at the moment…

Was there any progress on this? I’m using hassbian and I just got those sensors (I probably should have read this forum first) and they do not read temperature. Is there a workaround for it? I’m running 0.100.1

I always have an unknown state after a reboot because HA doesn’t get a value from the sensor directly. The sensor only sends its value when there’s a change in temperature or when you press the button on it. So press the button and see if that fixes your problem.


Anyone found a way to make it work?

this solved it: